VISION 4.5a is out!

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

JeanMars
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 111
Joined: Fri Apr 09, 2010 5:15 pm
Location: France
Contact:

Re: VISION 4.5a is out!

Postby JeanMars » Wed Jan 16, 2019 11:00 pm

Will try on my own tomorrow

JeanMars
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 111
Joined: Fri Apr 09, 2010 5:15 pm
Location: France
Contact:

Re: VISION 4.5a is out!

Postby JeanMars » Thu Jan 17, 2019 6:51 pm

Hi,

just made some tests:

@eero: you're right, if it is a Falcon, AES popup usage is forced. However it is on purpose as regular Falcon AES version is 0x0330 and so VISION can't rely on appl_getinfo to know about popup features. I could remove this force but in this case, regular Falcon will lose AES popup support... Can you point me to the exact emutos file you are using? I tried on Hatari and it looks OK.
On Hatari, TOS 4.92 and ST-High resolution, help bubble display is correct (see attached picture); what is your configuration exactly?
In 4colors resolution, I agree this is buggy but honestly I won't fix it, this is too an exotic resolution to spend time on it...

@sashapont: On Aranym or Hatari 256 colors resolution mode, it works OK on my side. Does it happen only on Firebee? Send me vision.log to see if I see something wrong (make sure to have LoggingFlags = 1ff933f in vision.ini before starting VISION). Are you using "Save as..."? Please describe more your issue.

Cheers,
Jean
You do not have the required permissions to view the files attached to this post.

sashapont
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 138
Joined: Sat Jun 03, 2017 9:40 pm

Re: VISION 4.5a is out!

Postby sashapont » Fri Jan 18, 2019 11:22 am

JeanMars wrote:Hi,
@sashapont: On Aranym or Hatari 256 colors resolution mode, it works OK on my side. Does it happen only on Firebee? Send me vision.log to see if I see something wrong (make sure to have LoggingFlags = 1ff933f in vision.ini before starting VISION). Are you using "Save as..."? Please describe more your issue.

Cheers,
Jean


https://cloud.mail.ru/public/MAit/89dVLMJN7
Atari Falcon, Firebee

User avatar
rudis
Captain Atari
Captain Atari
Posts: 162
Joined: Mon Feb 14, 2011 9:41 am

Re: VISION 4.5a is out!

Postby rudis » Fri Jan 18, 2019 7:53 pm

your image is saved in d:\ but you search in d:\development ??

JeanMars
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 111
Joined: Fri Apr 09, 2010 5:15 pm
Location: France
Contact:

Re: VISION 4.5a is out!

Postby JeanMars » Fri Jan 18, 2019 9:44 pm

Hi sashapont,

yes looks like you are not looking in the folder where you saved the picture...
Also I guess you created the image from "New..." in file menu and newly image file is NEW.TIF.
TIF format is selected by VISION in this case when color mode is TrueColor (else IMG should be selected by VISION) and GIF format is not compatible with, I agree there should be some error message (there is one now but probably not in the version you're testing).
Please try again and make sure you're in 256c mode and post vision .log here (make sure to have LoggingFlags = 1ff933f in vision.ini before starting VISION).
If that helps, you can try VISION "nightly build" at http://vision.atari.org/download/temp/vision.zip, at least you should have an error message in TC mode for GIF saving.

Thanks,
Jean

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1949
Joined: Sun Jul 31, 2011 1:11 pm

Re: VISION 4.5a is out!

Postby Eero Tamminen » Fri Jan 18, 2019 11:15 pm

JeanMars wrote:@eero: you're right, if it is a Falcon, AES popup usage is forced. However it is on purpose as regular Falcon AES version is 0x0330 and so VISION can't rely on appl_getinfo to know about popup features. I could remove this force but in this case, regular Falcon will lose AES popup support...


According to SYSINFO, EmuTOS v0.9.10 reports AES version 1.4:

Code: Select all

TYPE           : FALCON030
PROCESSOR      : 68030
FREQUENCY      : 16 MHz
TOS VERSION    : 2.06
GEM VERSION    : 0.20
AES VERSION    : 1.40


So things will still work fine with TOS versions supporting higher AES versions, if you select popup type based on the available AES version (instead of on which type of machine Vision runs on).

JeanMars wrote:Can you point me to the exact emutos file you are using? I tried on Hatari and it looks OK.


On Falcon (and TT) you should be using 512k image. I was using the latest release, v0.9.10.

While most of the Vision works fine with EmuTOS, the problem is that popup menus don't work on Falcon (on other machines they do). See above.

JeanMars wrote:On Hatari, TOS 4.92 and ST-High resolution, help bubble display is correct (see attached picture); what is your configuration exactly?


They look OK in monochrome / ST-high with TOS v4, but NOT with TOS v1, v2 or v3.

JeanMars wrote:In 4colors resolution, I agree this is buggy but honestly I won't fix it, this is too an exotic resolution to spend time on it...


I was only suggesting adding a dialog at start which says that 4-color is not a supported resolution and e.g. quitting.
Last edited by Eero Tamminen on Fri Jan 18, 2019 11:33 pm, edited 1 time in total.

JeanMars
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 111
Joined: Fri Apr 09, 2010 5:15 pm
Location: France
Contact:

Re: VISION 4.5a is out!

Postby JeanMars » Fri Jan 18, 2019 11:32 pm

Hi Eero,

appl_getinfo is only available on TOS > 4.00; for regular Falcon (I mean running original TOS) version is 3.30. So there is a special case on this because VISION knows it features popups. What I can do is to test against this version (3.30) for Falcon to not use AES popups in your case.

For monochrome, can you please make a screenshot? That may help me understand where the problem is.

OK for 4color resolutions, I can add a warning message to let user decide if he wants to continue or not, as if icon is the only issue, he can use other means (meu, keybooard and help bubbles).

Thanks for reporting these issues, I'll post a message here when a version is ready to be tested.
Jean

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1949
Joined: Sun Jul 31, 2011 1:11 pm

Re: VISION 4.5a is out!

Postby Eero Tamminen » Fri Jan 18, 2019 11:49 pm

Why do you need appl_getinfo()? appl_init() should already tell you the AES version, in all TOS versions.

(Besides, AFAIK all TOS functions return the function number if TOS didn't recognize the function. I assume the same applies also to AES functions like appl_getinfo(). If yes, you could also check its return value and perhaps assume AES to be too old if the call returns something else than success value.)

Screenshot of the monochrome problem:
grab0001.png
You do not have the required permissions to view the files attached to this post.

gstoll
Atari freak
Atari freak
Posts: 72
Joined: Sun Feb 17, 2008 4:29 pm

Re: VISION 4.5a is out!

Postby gstoll » Sat Jan 19, 2019 7:01 am

Eero Tamminen wrote:(Besides, AFAIK all TOS functions return the function number if TOS didn't recognize the function. I assume the same applies also to AES functions like appl_getinfo().

If you call a AES function which is not present, then came a Alert box with the function number.

If you want test for appl_getinfo you can use this:
https://freemint.github.io/tos.hyp/en/a ... l_xgetinfo

For the function "is_magic" use this: https://freemint.github.io/tos.hyp/en/magic_test.html

JeanMars
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 111
Joined: Fri Apr 09, 2010 5:15 pm
Location: France
Contact:

Re: VISION 4.5a is out!

Postby JeanMars » Sat Jan 19, 2019 9:24 pm

Hi,

If you want test for appl_getinfo you can use this:
https://freemint.github.io/tos.hyp/en/a ... l_xgetinfo


Problem with this routine is that it won't return support for a classic Falcon as AES is 3.30.
I have added test for AES version >= 3.30 if Falcon is detected.
Please test it at: http://vision.atari.org/download/temp/vision.zip

I also added a warning message for 4color modes.

Thanks for the screenshot in monochrome, I'll have a look.

Let me know if version above is better for you.
Cheers,
Jean

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1949
Joined: Sun Jul 31, 2011 1:11 pm

Re: VISION 4.5a is out!

Postby Eero Tamminen » Mon Jan 21, 2019 10:50 pm

JeanMars wrote:Problem with this routine is that it won't return support for a classic Falcon as AES is 3.30.
I have added test for AES version >= 3.30 if Falcon is detected.
Please test it at: http://vision.atari.org/download/temp/vision.zip

I also added a warning message for 4color modes.


Popup menus work now also with EmuTOS and the warning looks good!

However, after testing with Hatari VDI mode, I noticed that the toolbar icon issue isn't related to the number of colors, but resolution. Vision seems to be using wrong icons in 2-color mode when screen height is <400 pixels. If 2-color mode screen height is >= 400 pixels, icons look fine. See the screenshots:
vision-stmed.png
vision-vdi-2planes.png

Could you change 16-color icons to be used only when screen supports 16 or more colors?
You do not have the required permissions to view the files attached to this post.

JeanMars
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 111
Joined: Fri Apr 09, 2010 5:15 pm
Location: France
Contact:

Re: VISION 4.5a is out!

Postby JeanMars » Tue Jan 22, 2019 7:40 am

Hi Eero,

then something should be wrong in VISIONB.RSC; I'll have a look. Thanks for reporting.

Cheers,
Jean


Social Media

     

Return to “Applications”

Who is online

Users browsing this forum: No registered users and 5 guests

cron