SpeedoGDOS Laserjet Driver

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

LuigiThirty
Atari maniac
Atari maniac
Posts: 75
Joined: Sat Sep 03, 2016 12:20 am

SpeedoGDOS Laserjet Driver

Postby LuigiThirty » Thu Feb 01, 2018 2:46 am

I installed SpeedoGDOS on my ST and noticed there's a Laserjet driver included in the package. Is that just plain PCL and hence compatible with all the basic Laserjets? I have a 5P in storage but I'd rather not trek across town to grab it if it won't work with GDOS. Being able to print from TOS would be pretty cool.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12496
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: SpeedoGDOS Laserjet Driver

Postby wongck » Thu Feb 01, 2018 6:05 am

From what source code of gdos printer drivers available from the Internet that I have seen, it does seems so.
Mostly are sending ESC codes to the printer and these looks similar to PCL.
They may well be PCL.... IDK because I do not read PCL.

However, NVDI supports more printers and so should support your 5p better.
http://www.nvdi.de/gb/NVDI5.html#Supported_printers
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

LuigiThirty
Atari maniac
Atari maniac
Posts: 75
Joined: Sat Sep 03, 2016 12:20 am

Re: SpeedoGDOS Laserjet Driver

Postby LuigiThirty » Sun Feb 04, 2018 4:16 am

I found the NVDI 5 distribution and installed it - my ST just locks up during boot now. XBOOT says my run order is TOSRAM (to install 2.06), WDIALOG (required according to the manual, since I'm not running MagiC), then NVDI. I get the NVDI 5.03 splash text and nothing - no errors or disk activity. Disabling NVDI lets me boot again. I have 4MB in a 1040STF.

Is there a newer distribution than 5.03 or did I do something wrong with my run order?
Last edited by LuigiThirty on Sun Feb 04, 2018 7:27 am, edited 1 time in total.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12496
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: SpeedoGDOS Laserjet Driver

Postby wongck » Sun Feb 04, 2018 7:21 am

TOS RAM ?
Did you try without that?
My Stuff: FB/Falcon CT63/CTPCI+ATI+RTL8139+USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

LuigiThirty
Atari maniac
Atari maniac
Posts: 75
Joined: Sat Sep 03, 2016 12:20 am

Re: SpeedoGDOS Laserjet Driver

Postby LuigiThirty » Sun Feb 04, 2018 7:29 am

wongck wrote:TOS RAM ?
Did you try without that?


No luck running in Rainbow TOS. I'll try reinstalling NVDI, maybe there's crap left over from Speedo that's messing it up.

LuigiThirty
Atari maniac
Atari maniac
Posts: 75
Joined: Sat Sep 03, 2016 12:20 am

Re: SpeedoGDOS Laserjet Driver

Postby LuigiThirty » Sun Feb 04, 2018 7:40 am

Yeah, that fixed it. The ASSIGN.SYS was pointing to Speedo drivers that didn't exist anymore.


Social Media

     

Return to “Applications”

Who is online

Users browsing this forum: No registered users and 6 guests