zview maintainer

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12789
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: zview maintainer

Postby wongck » Fri Jul 07, 2017 3:35 pm

:megaphone: job for LP :wink:
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
lp
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2454
Joined: Wed Nov 12, 2003 11:09 pm
Location: GFA Headquarters
Contact:

Re: zview maintainer

Postby lp » Fri Jul 07, 2017 4:13 pm

Me and gcc don't play well together. That's a job for someone with far more patients than me. :lol:

PeterS
Captain Atari
Captain Atari
Posts: 256
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Re: zview maintainer

Postby PeterS » Sat Jul 08, 2017 12:28 pm

The instructions on SourceForge for making zView show it isn't straightforward. The make file is set up for cross compiling as well.


Maybe someone could be persuaded to put it into a github travis build like the new Freemint stuff.

gstoll
Atari freak
Atari freak
Posts: 74
Joined: Sun Feb 17, 2008 4:29 pm

Re: zview maintainer

Postby gstoll » Tue Oct 31, 2017 4:59 pm

About the WDialog printer dialog:
wongck wrote:Booted Mint 1.19+ XaAES with SpeedoGdos.... the Wdialog does not open up.

That can not work, because you need the VDI function from 180 to 182. And at the moment they only in NVDI.

wongck wrote:May be it just test for NVDi cookie?

Yes, XaAES test the cookie.

PeterS
Captain Atari
Captain Atari
Posts: 256
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Re: zview maintainer

Postby PeterS » Sun Dec 09, 2018 12:41 pm

I just downloaded zView 1.0.1 sources from SF and it fails to fetch pdf tools because the ftp site has moved/gone.

Has anyone tried to build it recently ? It would be good to fix this and be able to build zView.

ThorstenOtto
Atari Super Hero
Atari Super Hero
Posts: 853
Joined: Sun Aug 03, 2014 5:54 pm

Re: zview maintainer

Postby ThorstenOtto » Sun Dec 09, 2018 12:55 pm

PeterS wrote:Has anyone tried to build it recently ? It would be good to fix this and be able to build zView.


Yes, i used version 3.04 from https://xpdfreader-dl.s3.amazonaws.com/ ... .04.tar.gz

You may have to change the version and the download link in zview/Makefile.

ThorstenOtto
Atari Super Hero
Atari Super Hero
Posts: 853
Joined: Sun Aug 03, 2014 5:54 pm

Re: zview maintainer

Postby ThorstenOtto » Sun Dec 09, 2018 12:58 pm

gstoll wrote:at the moment they only in NVDI.


That's not entirely true. The pdlg_ functions are made available by Wdialog.prg. However, without NVDI or SpeedoGDOS, they are not very useful since it won't find any printer driver files (amongst others, the settings of the drivers are stored inside the driver file).

PeterS
Captain Atari
Captain Atari
Posts: 256
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Re: zview maintainer

Postby PeterS » Mon Dec 17, 2018 2:37 pm

ThorstenOtto wrote:
PeterS wrote:Has anyone tried to build it recently ? It would be good to fix this and be able to build zView.


Yes, i used version 3.04 from https://xpdfreader-dl.s3.amazonaws.com/ ... .04.tar.gz

You may have to change the version and the download link in zview/Makefile.



I downloaded and built xpdf (4.00) separately, modified the diff manually but it worked.

Then I downloaded and built FreeType2.

I all ready have Windom installed (I think) so I left that alone.

Struggling with the next step where says edit the file but doesn't say what to change.

ThorstenOtto
Atari Super Hero
Atari Super Hero
Posts: 853
Joined: Sun Aug 03, 2014 5:54 pm

Re: zview maintainer

Postby ThorstenOtto » Mon Dec 17, 2018 4:07 pm

PeterS wrote:I all ready have Windom installed (I think) so I left that alone.


You have to watch out there. Some of the apps (like zweather) need windom2 (using windom.h and libwindom.a), but zview itself needs the older windom 1.21 (using windom1.h and libwindom1.a)

Struggling with the next step where says edit the file but doesn't say what to change.


Which file?

mikro
Hardware Guru
Hardware Guru
Posts: 2035
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: zview maintainer

Postby mikro » Tue Dec 18, 2018 8:08 am

ThorstenOtto wrote:
PeterS wrote:
Struggling with the next step where says edit the file but doesn't say what to change.


Which file?

If he refers to howto.txt then I think it's pretty explicit:

6. Edit the path to libfreetype2 in the toplevel Makefile.
7. make


Social Media

     

Return to “Applications”

Who is online

Users browsing this forum: No registered users and 2 guests