Crazy Climber [Arcade]

https://github.com/MiSTer-devel/Main_MiSTer/wiki

Moderators: Mug UK, Zorro 2, spiny, Greenious, Sorgelig, Moderator Team

NML32
Captain Atari
Captain Atari
Posts: 490
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Crazy Climber [Arcade]

Postby NML32 » Fri Jun 08, 2018 3:54 pm

I'm experiencing some odd issues with this core related to left and right movements and saving joypad settings.
It seems the joypad settings are lost each time the core is started and sometimes left and right movement either by keyboard or joystick is buggy and doesn't work.
Sometimes I'm lucky and restarting the core and redefining the joystick works including the keyboard inputs for movement.

I also noticed while playing the game if I press the OSD button it toggles autofire when no other buttons are pressed. I don't think this should happen.

Besides that, I'm really enjoying the MiSTer Crazy Climber core. :D

NML32
Captain Atari
Captain Atari
Posts: 490
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Re: Crazy Climber [Arcade]

Postby NML32 » Fri Jun 08, 2018 7:35 pm

I'm curious, is anyone else having similar issues?

Martin8bity
Atarian
Atarian
Posts: 7
Joined: Mon Aug 18, 2014 11:12 am

Re: Crazy Climber [Arcade]

Postby Martin8bity » Fri Jun 08, 2018 8:44 pm

Me too. The lef/right movement is strange and sometimes it does not allow you to move when it should be possible.

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2079
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Crazy Climber [Arcade]

Postby Sorgelig » Sat Jun 09, 2018 9:45 am

NML32 wrote:I'm curious, is anyone else having similar issues?

it looks like not core issue but MiSTer binary. Can you try several previous versions and see if problem disappear.

Another problem can be a USB Hub issue. I remember you've got the MiSTer USB Hub. Actually it's not really hub issue but linux USB host driver of DE10-nano. It still has some problems sometimes. Sometimes plug joystick to other USB port solves the problem.

NML32
Captain Atari
Captain Atari
Posts: 490
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Re: Crazy Climber [Arcade]

Postby NML32 » Sat Jun 09, 2018 1:41 pm

Thanks for the suggestions but none of them seemed to help the issue.

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2079
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Crazy Climber [Arcade]

Postby Sorgelig » Sun Jun 10, 2018 5:02 am

Is it happening only with this core?

NML32
Captain Atari
Captain Atari
Posts: 490
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Re: Crazy Climber [Arcade]

Postby NML32 » Sun Jun 10, 2018 11:33 am

Sorgelig wrote:Is it happening only with this core?

Yes

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2079
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Crazy Climber [Arcade]

Postby Sorgelig » Sun Jun 10, 2018 11:57 am

Weird because that autofire message is not connected to specific core.
I believe you didn't use the joystick with other cores as extensively as with this core. This core requires a lot of quick presses several buttons. Try some other core with such many quick presses at the same time.

NML32
Captain Atari
Captain Atari
Posts: 490
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Re: Crazy Climber [Arcade]

Postby NML32 » Sun Jun 10, 2018 12:57 pm

Sorgelig wrote:Weird because that autofire message is not connected to specific core.
I believe you didn't use the joystick with other cores as extensively as with this core. This core requires a lot of quick presses several buttons. Try some other core with such many quick presses at the same time.

I agree this is weird. I'm not just having issues with my joystick I'm also having issues with the keyboard when trying to move left or right. So I'm not sure if the joystick is to blame.
Could you recommend a core to test as I've used this joystick with many cores and haven't had a problem?

I only get the autofire message if I try to press the OSD button while the game is in progress. I assume this doesn't happen for anyone else in the Crazy Climber core?

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2079
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Crazy Climber [Arcade]

Postby Sorgelig » Sun Jun 10, 2018 1:07 pm

autofire message appeared because one of key is stuck pressed.
I have similar problem with one joystick, while other joystick has no such issue.
I cannot tell where is the problem exactly - in input device handling procedure (in MiSTer binary) or in USB host driver which is still far from perfect.

NML32
Captain Atari
Captain Atari
Posts: 490
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Re: Crazy Climber [Arcade]

Postby NML32 » Sun Jun 10, 2018 1:23 pm

Sorgelig wrote:autofire message appeared because one of key is stuck pressed.
I have similar problem with one joystick, while other joystick has no such issue.
I cannot tell where is the problem exactly - in input device handling procedure (in MiSTer binary) or in USB host driver which is still far from perfect.

Thanks, now I understand.
Could you recommend a few wireless joysticks that you have tested that work better than others?

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2079
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Crazy Climber [Arcade]

Postby Sorgelig » Sun Jun 10, 2018 1:35 pm

8bitDo SF30Pro + 8bitDo USB receiver - for me it works solidly.

Martin8bity
Atarian
Atarian
Posts: 7
Joined: Mon Aug 18, 2014 11:12 am

Re: Crazy Climber [Arcade]

Postby Martin8bity » Sun Jun 10, 2018 2:53 pm

I tried keyboard and XBOX controller, but both behave similar. Did you try to control it with a keyboard?

NML32
Captain Atari
Captain Atari
Posts: 490
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Re: Crazy Climber [Arcade]

Postby NML32 » Mon Jun 11, 2018 1:30 pm

Martin8bity wrote:I tried keyboard and XBOX controller, but both behave similar. Did you try to control it with a keyboard?

Who are you asking?
It doesn’t matter if I use keyboard or joypad?

Martin8bity
Atarian
Atarian
Posts: 7
Joined: Mon Aug 18, 2014 11:12 am

Re: Crazy Climber [Arcade]

Postby Martin8bity » Mon Jun 11, 2018 3:13 pm

Anyone ;-) I think the default keybaord mapping was WASD left joy and arrows right joy, but it doeas note work for me, even if I try to reconfigure it to different keys.

NML32
Captain Atari
Captain Atari
Posts: 490
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Re: Crazy Climber [Arcade]

Postby NML32 » Mon Jun 11, 2018 11:02 pm

I disconnected my wireless Logitech K400 Plus keyboard including all my wireless joysticks (1) and connected my Logitech K120 USB keyboard and had much better luck with controlling left and right movement. Got stuck a few times moving L & R but not nearly as much as my wireless keyboard.

Then I tried my iBuffalo Classic USB Gamepad and mapped the Dpad for the left hand and A,X,Y,B buttons for the right hand and had very good results.
The OSD button worked in-game (No Auto Fire message).

Both my dual thumbstick joysticks are wireless so I''m wondering if the issue is wireless or the analog thumbsticks.

Note: I've only seen this odd behavior in the Crazy Climber core.

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2079
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Crazy Climber [Arcade]

Postby Sorgelig » Tue Jun 12, 2018 6:47 am

for me it still looks like USB host driver issue.
Try to plug your USB devices in different configs to identify which USB device start to produce this problem.
Also you can try to move devices into different USB ports.

brunosilva
Retro freak
Retro freak
Posts: 10
Joined: Mon Apr 09, 2018 10:58 pm

Re: Crazy Climber [Arcade]

Postby brunosilva » Sat Jun 16, 2018 12:50 pm

hi

what's the md5 for the crazy climber rom? B6B06723DA0F0E6E183723285B0BF5BE ?

NML32
Captain Atari
Captain Atari
Posts: 490
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Re: Crazy Climber [Arcade]

Postby NML32 » Sat Jun 16, 2018 1:23 pm

brunosilva wrote:hi

what's the md5 for the crazy climber rom? B6B06723DA0F0E6E183723285B0BF5BE ?

That matches mine.


Return to “MiSTer”

Who is online

Users browsing this forum: No registered users and 1 guest