Joystick testing thread

https://github.com/MiSTer-devel/Main_MiSTer/wiki

Moderators: Mug UK, Zorro 2, Greenious, spiny, Sorgelig, Moderator Team

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4631
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Joystick testing thread

Postby Sorgelig » Wed Apr 17, 2019 8:50 am

Both brown and grey bricks are supported. I recommend to read the thread before asking the questions.

jpxdude
Retro freak
Retro freak
Posts: 13
Joined: Mon Nov 19, 2018 9:25 pm

Re: Joystick testing thread

Postby jpxdude » Sun Apr 21, 2019 6:43 pm

Hi there,

I have a bit of an odd issue which I hope someone could help with. I have updated my MiSTer build using the updated script. I usually use a wireless Xbox 360 controller which has worked fine with SNES until now, however it is now not behaving properly.

I have mapped the controller in the menu, and again in the SNES core, but now for some reason, the D-Pad only registers ‘right’ presses in game. Up, left and down are not recognised. It works fine within menus which is the odd thing, just not in any loaded games.

Anyone know what is causing this? Thanks in advance for your help.

LarsDragon
Atariator
Atariator
Posts: 24
Joined: Sun Dec 10, 2017 12:08 am

Re: Joystick testing thread

Postby LarsDragon » Sun Apr 21, 2019 8:27 pm

I have the same problem with Snes type usb joypad, perhaps is caused by the last update.

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4631
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Joystick testing thread

Postby Sorgelig » Sun Apr 21, 2019 10:15 pm

Not enough info to understand.
For me it works fine.

LarsDragon
Atariator
Atariator
Posts: 24
Joined: Sun Dec 10, 2017 12:08 am

Re: Joystick testing thread

Postby LarsDragon » Mon Apr 22, 2019 6:19 am

Sorgelig wrote:Not enough info to understand.
For me it works fine.

I use a mayflash wii classic controller adapter with two ports and now if redefine the controler, only right direction and butrons work, thats not happen before. With my 8bitdo bluetooth work well.

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4631
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Joystick testing thread

Postby Sorgelig » Mon Apr 22, 2019 7:43 am

I don't have "Mayflash wii classic adapter", but i have "Mayflash Magic-NS Wireless Controller Adapter" which works fine with DualShock 3 gamepad.
I believe these adapters share common behaviour as they are from the same manufacturer.
I think, it's usual: you didn't re-define the gamepad in Menu core.

LarsDragon
Atariator
Atariator
Posts: 24
Joined: Sun Dec 10, 2017 12:08 am

Re: Joystick testing thread

Postby LarsDragon » Mon Apr 22, 2019 8:43 am

Sorgelig wrote:I don't have "Mayflash wii classic adapter", but i have "Mayflash Magic-NS Wireless Controller Adapter" which works fine with DualShock 3 gamepad.
I believe these adapters share common behaviour as they are from the same manufacturer.
I think, it's usual: you didn't re-define the gamepad in Menu core.

Only happens after re-define the gamepad in Menu core.
I will try with a previous version of main Mister file, and report if it work well.

LarsDragon
Atariator
Atariator
Posts: 24
Joined: Sun Dec 10, 2017 12:08 am

Re: Joystick testing thread

Postby LarsDragon » Mon Apr 22, 2019 12:59 pm

LarsDragon wrote:
Sorgelig wrote:I don't have "Mayflash wii classic adapter", but i have "Mayflash Magic-NS Wireless Controller Adapter" which works fine with DualShock 3 gamepad.
I believe these adapters share common behaviour as they are from the same manufacturer.
I think, it's usual: you didn't re-define the gamepad in Menu core.

Only happens after re-define the gamepad in Menu core.
I will try with a previous version of main Mister file, and report if it work well.

Sorry Sorgelig, It is the same issue reported in:
viewtopic.php?f=117&t=34873&p=372805#p372805

Lodovic
Atariator
Atariator
Posts: 26
Joined: Thu Nov 22, 2018 2:51 am

Re: Joystick testing thread

Postby Lodovic » Mon Apr 22, 2019 9:26 pm

Hi,

I was a couple of weeks without updating and today I updated both the cores, Mister and the Linux part with the update script.

I see there was quite a few changes in the input support and I miss something I had before:

Before, I could use interchangeably the D-Pad and the left analog stick on almost every core and now, this doesn't work anymore on the SNES and 1942 cores, for example but it's working on the OSD menu. I've checked the Wiki but didn't find anything wrong in the way I've setup my PS4 controller connected through the 8Bitdo orange brick. I've redone the input setup in both (the cores and in the Mister OSD) and still can't get it to work with the left analog on the SNES. The Genesis core is OK, though. The 1942 core was easier with the left analog because the PS4 D-Pad is not my favorite.

Did I miss something?

*Edit*: Found a workaround: If I use the analog stick to define the controls in the core menu, both the D-Pad and analog stick are enabled in the cores I mentioned.

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4631
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Joystick testing thread

Postby Sorgelig » Tue Apr 23, 2019 2:27 pm

There is a change in latest release.
Before Alt/Mouse controls are used as alternative directional control in every core.
Now you can define 2 alternative controls per gamepad in every core as you like. You just need to run button definition dialog 2 times. First start of dialog - defines first set. Second start - second set. Third start will will define 1 set and so on altering between 2 sets.
If you start button definition only once then it will behave as before Alt/mouse directions will be used.

So you can define dpad in first set and analog stick as dpad in second set.

Lodovic
Atariator
Atariator
Posts: 26
Joined: Thu Nov 22, 2018 2:51 am

Re: Joystick testing thread

Postby Lodovic » Wed Apr 24, 2019 1:38 am

This is great! Thanks, Sorgelig.

snkplay
Atarian
Atarian
Posts: 1
Joined: Tue Apr 30, 2019 11:23 pm

Re: Joystick testing thread

Postby snkplay » Wed May 01, 2019 12:46 am

So I've tried configuring the pad in the 'Define joystick buttons' (without a hub so hotswapping keyboard/controller) when I try to use the controller I get the 'you need to define this joystick in menu core first' message.


Edit: All issues went away when setting up the controller using a hub.

Sorgelig
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4631
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Joystick testing thread

Postby Sorgelig » Wed May 15, 2019 2:31 pm

Finally got X360 wireless receiver. Tested my X360 wireless gamepad - works fine. Special tweaks aren't required.

warham
Atari maniac
Atari maniac
Posts: 77
Joined: Fri Oct 12, 2018 7:17 am

Re: Joystick testing thread

Postby warham » Thu May 16, 2019 7:33 am

Sorgelig wrote:Finally got X360 wireless receiver. Tested my X360 wireless gamepad - works fine. Special tweaks aren't required.


Whatever you have been doing to make USB better is working!
Newest revision of 7 port Dlink hub is now working with 2 switch pro controllers connected to 8bitdo orange bricks., Bluetooth, wifi, keyboard.

Previously, one players buttons would start out ok and slowly stop functioning.
Flying in 2 player Joust was a little unfair :p
Controllers also keep functioning when mister is reset, where as before they would lose function upon resetting and require a power cycle.

Thanks for the wireless x360 info, in the past the right stick was not recognized.

caver99
Atariator
Atariator
Posts: 29
Joined: Thu May 19, 2011 5:11 am

Re: Joystick testing thread

Postby caver99 » Fri May 31, 2019 2:25 pm

i have a generic xbox 360 to usb adapter which i plugged into the pc and synced the controller to and moved to the mister and the xbox 360 controller works like a charm in every core and i have the xbox button set up as the magic menu button.
i haven't checked as yet if 2 controllers work for 2 player games as yet.

digitron
Atari nerd
Atari nerd
Posts: 45
Joined: Sat Apr 20, 2019 7:27 pm

Re: Joystick testing thread

Postby digitron » Fri Jun 21, 2019 7:16 pm

8BITDO SF30, I can get the Star button to work if I hold Y + Start (Switch mode) but I can't seem to get the Menu button working, anyone else have this issue?


Return to “MiSTer”

Who is online

Users browsing this forum: No registered users and 2 guests

cron