Trouble with swedish TOS

https://github.com/mist-devel/mist-board/wiki

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

solskogen
Atari User
Atari User
Posts: 42
Joined: Sun Jul 27, 2008 4:03 pm

Trouble with swedish TOS

Postby solskogen » Sun Nov 04, 2018 12:58 pm

Swedish TOS (1.62) does not seem to work on my Mist. UK and American works just fine. Does anybody else have that problem as well?
I only get a black screen with tos162se.

User avatar
MasterOfGizmo
Atari God
Atari God
Posts: 1215
Joined: Fri Feb 08, 2013 12:15 pm
Contact:

Re: Trouble with swedish TOS

Postby MasterOfGizmo » Tue Nov 13, 2018 8:56 pm

Can you provide a link to that version?
MIST board, FPGA based Atari STE and more: https://github.com/mist-devel/mist-board/wiki

solskogen
Atari User
Atari User
Posts: 42
Joined: Sun Jul 27, 2008 4:03 pm

Re: Trouble with swedish TOS

Postby solskogen » Wed Nov 14, 2018 1:10 pm


solskogen
Atari User
Atari User
Posts: 42
Joined: Sun Jul 27, 2008 4:03 pm

Re: Trouble with swedish TOS

Postby solskogen » Wed Nov 14, 2018 1:42 pm

I can get Mono to work if I reset the MiST a few times, but no luck with color.

User avatar
MasterOfGizmo
Atari God
Atari God
Posts: 1215
Joined: Fri Feb 08, 2013 12:15 pm
Contact:

Re: Trouble with swedish TOS

Postby MasterOfGizmo » Fri Nov 16, 2018 11:23 am

Tha ROM just works here. Make sure you setup an STE under Video/Chipset as TOS 1.62 will not run on an ordinary ST.
MIST board, FPGA based Atari STE and more: https://github.com/mist-devel/mist-board/wiki

solskogen
Atari User
Atari User
Posts: 42
Joined: Sun Jul 27, 2008 4:03 pm

Re: Trouble with swedish TOS

Postby solskogen » Wed Nov 21, 2018 2:28 pm

Hmf, perhaps my monitor is not fully compatible with it. TOS102 works just fine :(

User avatar
MasterOfGizmo
Atari God
Atari God
Posts: 1215
Joined: Fri Feb 08, 2013 12:15 pm
Contact:

Re: Trouble with swedish TOS

Postby MasterOfGizmo » Thu Nov 22, 2018 7:06 am

solskogen wrote:Hmf, perhaps my monitor is not fully compatible with it. TOS102 works just fine :(


The video timing is hardwired in the core. The TOS does not affect it except that some TOS set 50Hz PAL modes and some set 60Hz NTSC modes.
MIST board, FPGA based Atari STE and more: https://github.com/mist-devel/mist-board/wiki

ThorstenOtto
Captain Atari
Captain Atari
Posts: 455
Joined: Sun Aug 03, 2014 5:54 pm

Re: Trouble with swedish TOS

Postby ThorstenOtto » Thu Nov 22, 2018 7:31 am

solskogen wrote:some TOS set 50Hz PAL modes and some set 60Hz NTSC modes.


Normally, only the US version uses PAL mode, all other (european) version use NTSC. Unless you patched the config bit in the ROM header (least significant bit of byte 29).

joska
Hardware Guru
Hardware Guru
Posts: 4186
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: Trouble with swedish TOS

Postby joska » Thu Nov 22, 2018 8:22 am

solskogen wrote:Hmf, perhaps my monitor is not fully compatible with it. TOS102 works just fine :(


Is your MiST set up as an STE like MasterOfGizmo advised you? If not, you want TOS 1.04, not 1.6.
Jo Even

VanillaMiNT - Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64

solskogen
Atari User
Atari User
Posts: 42
Joined: Sun Jul 27, 2008 4:03 pm

Re: Trouble with swedish TOS

Postby solskogen » Thu Nov 22, 2018 9:33 am

Yes, it is. Tried all of them: STe, STeroids and MegaSTe.

solskogen
Atari User
Atari User
Posts: 42
Joined: Sun Jul 27, 2008 4:03 pm

Re: Trouble with swedish TOS

Postby solskogen » Thu Nov 22, 2018 9:35 am

ThorstenOtto wrote:
solskogen wrote:some TOS set 50Hz PAL modes and some set 60Hz NTSC modes.


Normally, only the US version uses PAL mode, all other (european) version use NTSC. Unless you patched the config bit in the ROM header (least significant bit of byte 29).


You mean the other way around, right?

solskogen
Atari User
Atari User
Posts: 42
Joined: Sun Jul 27, 2008 4:03 pm

Re: Trouble with swedish TOS

Postby solskogen » Thu Nov 22, 2018 10:04 am

Tried with another monitor. Worked like a charm.

ThorstenOtto
Captain Atari
Captain Atari
Posts: 455
Joined: Sun Aug 03, 2014 5:54 pm

Re: Trouble with swedish TOS

Postby ThorstenOtto » Thu Nov 22, 2018 11:35 am

solskogen wrote:You mean the other way around, right?


Oops, right. Got a bit confused.


Return to “MiST”

Who is online

Users browsing this forum: No registered users and 5 guests