New Amiga core beta :D

https://github.com/mist-devel/mist-board/wiki

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

User avatar
vebxenon
Atari Super Hero
Atari Super Hero
Posts: 618
Joined: Fri Apr 24, 2015 12:10 pm

New Amiga core beta :D

Postby vebxenon » Thu May 31, 2018 6:09 am

New beta 1.2.3 has been released

http://somuch.guru/minimig/minimig-mist/

:cheers:

On main MiST community on Facebook they said that there are new bugfixes backported from MiSTer.

https://m.facebook.com/home.php?sk=live&_rdr#!/groups/1501669116809347?view=permalink&id=1821410721501850&fs=2&ref=m_notif&notif_t=feedback_reaction_generic

New firmware also is available!

Let's download it!
Just a computer and videogame lover :)

- Atari Jr 2600 clone
- Atari 7800 Peritel
- Atari XEGS
- Atari Lynx II
- Atari Jaguar
- MiST Board

AdvancedFollower
Atari User
Atari User
Posts: 33
Joined: Sun Oct 29, 2017 4:59 pm
Location: Uppsala, Sweden

Re: New Amiga core beta :D

Postby AdvancedFollower » Thu May 31, 2018 7:28 am

It's alive :)
Looks like just one bug fix from the Facebook post, but better than nothing. I agree with the commenter there, it would be really sweet if we could get 640x480p and beyond working without the weird glitches.

DanyPPC
Captain Atari
Captain Atari
Posts: 384
Joined: Tue Feb 21, 2017 7:02 am

Re: New Amiga core beta :D

Postby DanyPPC » Thu May 31, 2018 5:14 pm

No real change:
CD32 joypad not recognized (USB or real DB9), Pinball Illusions doesn't work as first, etc...

but hope it will be improved :shrug:

AdvancedFollower
Atari User
Atari User
Posts: 33
Joined: Sun Oct 29, 2017 4:59 pm
Location: Uppsala, Sweden

Re: New Amiga core beta :D

Postby AdvancedFollower » Fri Jun 01, 2018 9:53 am

Yep, still a few issues. Charlie J Cool still suffers from flickering sprites, Pinball Illusions still crashes upon loading a table.

I tried the Dbl modes and DblNTSC works better now. The mouse cursor looks good now both in High and Lores modes, although the cursor still seems to skip 2-3 pixels when you move the mouse (maybe that's an issue on actual Amigas too?). Using Overscan, I can get a nice, centered 640x480 picture. DblPAL still creates an off-center picture that's impossible to get fully on-screen even using Overscan, not sure if it's just my monitor or the FPGA core.

kolla
Captain Atari
Captain Atari
Posts: 163
Joined: Thu Sep 17, 2015 11:39 pm
Contact:

Re: New Amiga core beta :D

Postby kolla » Fri Jun 01, 2018 1:51 pm

I keep wondering why people want Multiscan modes... but then I remember that I use MagicTV on my 4 bit-plane PAL Hires Laced Workbench setup, lol :)

http://aminet.net/package/util/wb/magictv2
-- kolla

User avatar
DrOG
Captain Atari
Captain Atari
Posts: 436
Joined: Sun Jul 31, 2016 8:23 pm
Location: Gyula, Hungary

Re: New Amiga core beta :D

Postby DrOG » Fri Jun 01, 2018 4:03 pm

Hi!

Tried to play 'Monsters of Terror', without success. Downloaded many different versions from the author's (Lazy Cow) website and EAB's zone, but none of them worked. Tried many cores (1.2.1, 1.2.2 & 1.2.3) with different firmwares (from the one released in the january of 2017 to the most recent zipped with the latest core). Tried directly .adfs and install them to hd without luck. Has anyone a working version or combination?

Thanks: Gábor

DanyPPC
Captain Atari
Captain Atari
Posts: 384
Joined: Tue Feb 21, 2017 7:02 am

Re: New Amiga core beta :D

Postby DanyPPC » Fri Jun 01, 2018 5:07 pm

Same here, Monsters Of Terror doesn't work, but a lot of games work very well.

User avatar
DrOG
Captain Atari
Captain Atari
Posts: 436
Joined: Sun Jul 31, 2016 8:23 pm
Location: Gyula, Hungary

Re: New Amiga core beta :D

Postby DrOG » Fri Jun 01, 2018 6:28 pm

It's strange, tried with WinUAE using the recommended settings (68020 CPU, 2MB Chip RAM and WB 3.0/3.1), and it works flawless...

Perhaps this bug report will help the developers to improve the core!

AdvancedFollower
Atari User
Atari User
Posts: 33
Joined: Sun Oct 29, 2017 4:59 pm
Location: Uppsala, Sweden

Re: New Amiga core beta :D

Postby AdvancedFollower » Fri Jun 01, 2018 8:24 pm

Managed to get DblPAL working in BetterWB. The issue is when you save, all the icons turn pink and then the entire MiST eventually crashes with a Red Screen of Death. However if you hit the physical reset switch at this point, it boots normally.

Something still looks "off" though. Not sure that the aspect ration of the GlowIcons is right, and the text looks more "messy" than in regular PAL HiRes.
DblNTSC:
Image

DblPAL:
Image

Still probably going to stick with my PAL Overscan 16-color WB. It's faster and saves a bunch of Chip RAM.
Image

sardine
Atarian
Atarian
Posts: 7
Joined: Wed Jun 28, 2017 4:13 pm

Re: New Amiga core beta :D

Postby sardine » Sat Jun 02, 2018 12:14 am

I can see what's off with your screenshots.. your TV is trying to compensate like most modern TV/monitors clumsy pixel stretching.

see if your tv/monitor has pixel clock phase adjustment to get 1:1 pixel size.. I have an older Samsung 940mw that i can adjust to perfection.

for example on my monitor the checkerboard pattern is perfect,, on your tv i guess you get wave effect or shimmer on side scroll games like menace..

kolla
Captain Atari
Captain Atari
Posts: 163
Joined: Thu Sep 17, 2015 11:39 pm
Contact:

Re: New Amiga core beta :D

Postby kolla » Sat Jun 02, 2018 9:10 am

Or use a mode with same ratio as your monitor.

Remember that original Amiga icons were not displayed 1:1, but rather for PAL 5:2 (hires 620x256) or 5:4 (hires laced 640:512) stretched to a fit a 4:3 TV, NTSC is a tad better with actual 4:3 (or 8:3) ratio :) The OS3.5+ icons were made for RTG and 1:1 in mind though.
-- kolla


Return to “MiST”

Who is online

Users browsing this forum: DanyPPC and 5 guests