PCEngine core issues with roms?

https://github.com/mist-devel/mist-board/wiki

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

LarsDragon
Atari User
Atari User
Posts: 33
Joined: Sun Dec 10, 2017 12:08 am

Re: PCEngine core issues with roms?

Postby LarsDragon » Sun Feb 17, 2019 10:25 am

Hi Slingshot, in the new version there is grafical issue in Street Fighter II, in previous version work ok. The image glich some times.

slingshot
Atari God
Atari God
Posts: 1340
Joined: Mon Aug 06, 2018 3:05 pm

Re: PCEngine core issues with roms?

Postby slingshot » Tue Feb 19, 2019 9:24 am

LarsDragon wrote:Hi Slingshot, in the new version there is grafical issue in Street Fighter II, in previous version work ok. The image glich some times.

I didn't notice, what should I watch?

LarsDragon
Atari User
Atari User
Posts: 33
Joined: Sun Dec 10, 2017 12:08 am

Re: PCEngine core issues with roms?

Postby LarsDragon » Tue Feb 19, 2019 12:16 pm

slingshot wrote:
LarsDragon wrote:Hi Slingshot, in the new version there is grafical issue in Street Fighter II, in previous version work ok. The image glich some times.

I didn't notice, what should I watch?

In some fights the image flickers. I noticed it in Honda and Blanka stage, using a 15khz CRT TV. It does not happen constantly.

LarsDragon
Atari User
Atari User
Posts: 33
Joined: Sun Dec 10, 2017 12:08 am

Re: PCEngine core issues with roms?

Postby LarsDragon » Sun Mar 03, 2019 9:24 pm

Hi slingshot, I found a grafical error in the backgroud image in Air Zonk game, maybe it has something to do with the previous problem that I mentioned. The background is drawn more slowly than the image that is displayed, you need to play the game a little to see it in first stage.
Hope that helps :cheers:
Air Zonk.jpg
You do not have the required permissions to view the files attached to this post.

slingshot
Atari God
Atari God
Posts: 1340
Joined: Mon Aug 06, 2018 3:05 pm

Re: PCEngine core issues with roms?

Postby slingshot » Tue Mar 05, 2019 2:52 pm

LarsDragon wrote:Hi slingshot, I found a grafical error in the backgroud image in Air Zonk game, maybe it has something to do with the previous problem that I mentioned. The background is drawn more slowly than the image that is displayed, you need to play the game a little to see it in first stage.
Hope that helps :cheers:
Air Zonk.jpg

Didn't see it myself, but here's a similar report:
viewtopic.php?f=117&t=32496&start=200#p364845
I think it's not MiST specific bug.

LarsDragon
Atari User
Atari User
Posts: 33
Joined: Sun Dec 10, 2017 12:08 am

Re: PCEngine core issues with roms?

Postby LarsDragon » Tue Mar 05, 2019 8:29 pm

slingshot wrote:
LarsDragon wrote:Hi slingshot, I found a grafical error in the backgroud image in Air Zonk game, maybe it has something to do with the previous problem that I mentioned. The background is drawn more slowly than the image that is displayed, you need to play the game a little to see it in first stage.
Hope that helps :cheers:
Air Zonk.jpg

Didn't see it myself, but here's a similar report:
viewtopic.php?f=117&t=32496&start=200#p364845
I think it's not MiST specific bug.

It don´t seem to be the same problem, in Wonder Momo game that error does not happen to me. It seems to work better in Mist :D.
WonderMomo.jpg
You do not have the required permissions to view the files attached to this post.

slingshot
Atari God
Atari God
Posts: 1340
Joined: Mon Aug 06, 2018 3:05 pm

Re: PCEngine core issues with roms?

Postby slingshot » Tue Mar 05, 2019 11:02 pm

LarsDragon wrote:I think it's not MiST specific bug.

It don´t seem to be the same problem, in Wonder Momo game that error does not happen to me. It seems to work better in Mist :D.
WonderMomo.jpg[/quote]
Different boards, different bugs :)

seastalker
Captain Atari
Captain Atari
Posts: 298
Joined: Sun May 15, 2016 3:44 pm

Re: PCEngine core issues with roms?

Postby seastalker » Fri Mar 08, 2019 9:55 am

An interesting footnote on PC Engines. I wondered the difference between a Coregrafx I and II besides the look: a subtle CPU change history.

Original white PC-Engine used the HU6280 CPU.
CoreGrafx 1 used the HU6280a revised CPU and a wiki portion says "which supposedly fixed some minor audio issues."
CoreGrafx 2 switched BACK to the original HU6280 CPU.

It may seem trivial, but tidbits like this fascinate me. Which cpu is implemented by this core? Does anyone know more about why NEC made the change and then change back and how the revisions differ?

Beljos
Atarian
Atarian
Posts: 1
Joined: Thu May 30, 2019 6:24 pm

Re: PCEngine core issues with roms?

Postby Beljos » Thu May 30, 2019 6:26 pm

I play for a while PC Engine - TurboGrafx16 but when I load the game in the emulator freezes, I use RetroArch emulator can someone tell me what is the problem or I should instal a new emulator.

User avatar
Newsdee
Atari God
Atari God
Posts: 1504
Joined: Fri Sep 19, 2014 8:40 am

Re: PCEngine core issues with roms?

Postby Newsdee » Fri May 31, 2019 6:05 am

This thread is for the MiST core, not general emulators on PC . :D

DanyPPC
Atari Super Hero
Atari Super Hero
Posts: 783
Joined: Tue Feb 21, 2017 7:02 am

Re: PCEngine core issues with roms?

Postby DanyPPC » Mon Jun 03, 2019 2:10 pm

New release https://github.com/gyurco/FPGAPCE/releases/tag/190602
alters the colors when using the scanline effect

Thanks

DanyPPC
Atari Super Hero
Atari Super Hero
Posts: 783
Joined: Tue Feb 21, 2017 7:02 am

Re: PCEngine core issues with roms?

Postby DanyPPC » Mon Jun 03, 2019 6:04 pm

Ok, thanks Slingshot to fix scanline problem. :wink:


Return to “MiST”

Who is online

Users browsing this forum: No registered users and 3 guests