My MiST died...

https://github.com/mist-devel/mist-board/wiki

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

DrChaos
Atari freak
Atari freak
Posts: 64
Joined: Sun Feb 08, 2015 11:21 pm

My MiST died...

Postby DrChaos » Mon May 11, 2015 7:26 am

Hi,
I haven't used my MiST for a few weeks and when I wanted to used in on Friday I was unable to switch it on. I tried two diferent power supplies, but there is not even a flickering of light.
Any ideas?

Jenot
Retro freak
Retro freak
Posts: 11
Joined: Tue Aug 27, 2013 4:15 am

Re: My MiST died...

Postby Jenot » Mon May 11, 2015 9:17 am

Probably broken MicroUSB socket.

DrChaos
Atari freak
Atari freak
Posts: 64
Joined: Sun Feb 08, 2015 11:21 pm

Re: My MiST died...

Postby DrChaos » Mon May 11, 2015 1:37 pm

Well, although this is strange because the was no mechanical strain during the weeks I did't use it - this should be easy to find out with a multimeter. I think I will check that soon...

Dal
Administrator
Administrator
Posts: 4162
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: My MiST died...

Postby Dal » Mon May 11, 2015 1:48 pm

I took a look at the schematic, there are 3 DC regulators providing 3V, 2V and 1V. If you're getting your meter out, you should check these too.
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
MasterOfGizmo
Atari God
Atari God
Posts: 1215
Joined: Fri Feb 08, 2013 12:15 pm
Contact:

Re: My MiST died...

Postby MasterOfGizmo » Mon May 11, 2015 7:15 pm

There are indeed only very few parts between the power supply and the power led. If you dare you can try this approach: http://code.google.com/p/mist-board/wiki/PwrDcJack
MIST board, FPGA based Atari STE and more: https://github.com/mist-devel/mist-board/wiki

FedePede04
Atari God
Atari God
Posts: 1072
Joined: Fri Feb 04, 2011 12:14 am
Location: Denmark
Contact:

Re: My MiST died...

Postby FedePede04 » Mon May 11, 2015 8:01 pm

Jenot wrote:Probably broken MicroUSB socket.

+1
it happen to mine
Atari will rule the world, long after man has disappeared

sometime my English is a little weird, Google translate is my best friend :)

User avatar
Gryzor
Gryzorator
Gryzorator
Posts: 1560
Joined: Wed Jun 05, 2002 8:36 am
Location: Athens, Greece
Contact:

Re: My MiST died...

Postby Gryzor » Tue May 12, 2015 6:39 am

FedePede04 wrote:
Jenot wrote:Probably broken MicroUSB socket.

+1
it happen to mine


Mine, too...

I'm having my MiST modded (photos hopefully soon) and we dropped the USB power option, instead going for the proper power plug.
Reality is that, which, when you stop believing in it, doesn't go away. --P.K.Dick

.:.
http://gryzor.info

Image

DrChaos
Atari freak
Atari freak
Posts: 64
Joined: Sun Feb 08, 2015 11:21 pm

Re: My MiST died...

Postby DrChaos » Tue May 12, 2015 6:41 am

OK, I'll try this. It's a pity, because it's fairly new. I also wrote Lotharek but did not get a response yet.

User avatar
Gryzor
Gryzorator
Gryzorator
Posts: 1560
Joined: Wed Jun 05, 2002 8:36 am
Location: Athens, Greece
Contact:

Re: My MiST died...

Postby Gryzor » Tue May 12, 2015 6:44 am

Lotharek is very busy from what I understand, but he has always written back to me; he fixed mine when the USB broke.
Reality is that, which, when you stop believing in it, doesn't go away. --P.K.Dick

.:.
http://gryzor.info

Image

User avatar
Newsdee
Atari God
Atari God
Posts: 1220
Joined: Fri Sep 19, 2014 8:40 am

Re: My MiST died...

Postby Newsdee » Tue May 12, 2015 6:50 am

I recommend installing the ARM connector to program the firmware at the same time. The cable isn't cheap but it's the only way to recover from a failed firmware upgrade if you remove the usb power port.

User avatar
Gryzor
Gryzorator
Gryzorator
Posts: 1560
Joined: Wed Jun 05, 2002 8:36 am
Location: Athens, Greece
Contact:

Re: My MiST died...

Postby Gryzor » Tue May 12, 2015 6:59 am

Newsdee wrote:I recommend installing the ARM connector to program the firmware at the same time. The cable isn't cheap but it's the only way to recover from a failed firmware upgrade if you remove the usb power port.


Good idea, but I'm not removing the USB power port, just preferring not to use it. It'll still be there :)
Reality is that, which, when you stop believing in it, doesn't go away. --P.K.Dick

.:.
http://gryzor.info

Image

User avatar
Newsdee
Atari God
Atari God
Posts: 1220
Joined: Fri Sep 19, 2014 8:40 am

Re: My MiST died...

Postby Newsdee » Tue May 12, 2015 12:02 pm

Ah right, the mod on the wiki replaces the usb with a power plug, but I guess you could keep a usb port wired as well (just hidden inside the case).

User avatar
Gryzor
Gryzorator
Gryzorator
Posts: 1560
Joined: Wed Jun 05, 2002 8:36 am
Location: Athens, Greece
Contact:

Re: My MiST died...

Postby Gryzor » Tue May 12, 2015 1:38 pm

Newsdee wrote:Ah right, the mod on the wiki replaces the usb with a power plug, but I guess you could keep a usb port wired as well (just hidden inside the case).


No replacement needed, there's a header on the board to which you can attach a power socket...
Reality is that, which, when you stop believing in it, doesn't go away. --P.K.Dick

.:.
http://gryzor.info

Image

User avatar
MasterOfGizmo
Atari God
Atari God
Posts: 1215
Joined: Fri Feb 08, 2013 12:15 pm
Contact:

Postby MasterOfGizmo » Sat May 16, 2015 8:01 pm

Correct. The USB plug is not replaced. It just isn't used to power the board anymore after that mod.

I am sure Lotharek will answer. If he's busy it's a good sign. The more mist users the better :-)

Dal
Administrator
Administrator
Posts: 4162
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: My MiST died...

Postby Dal » Sun May 17, 2015 7:58 am

One more being added to the list too, I ordered mine last week.
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

DrChaos
Atari freak
Atari freak
Posts: 64
Joined: Sun Feb 08, 2015 11:21 pm

Re: My MiST died...

Postby DrChaos » Sun May 17, 2015 5:47 pm

Hi, it is the MicroUSB, this seems to be a common error if I understand this thread correctly. However, I think I need Lotahreks help, because I think I will not be able to replace it myself and I would like to stick with MicroUSB, because these are available everywhere...
I'll see if I can get in touch with him.

User avatar
Gryzor
Gryzorator
Gryzorator
Posts: 1560
Joined: Wed Jun 05, 2002 8:36 am
Location: Athens, Greece
Contact:

Re: My MiST died...

Postby Gryzor » Sun May 17, 2015 5:48 pm

Indeed, it's tiny and requires quite some experience with soldering to do it right...
Reality is that, which, when you stop believing in it, doesn't go away. --P.K.Dick

.:.
http://gryzor.info

Image

User avatar
farvardin
Captain Atari
Captain Atari
Posts: 367
Joined: Fri Jan 01, 2010 5:50 pm
Location: France
Contact:

Re: My MiST died...

Postby farvardin » Sun May 17, 2015 6:51 pm

Dal wrote:One more being added to the list too, I ordered mine last week.


so did I ;)


Return to “MiST”

Who is online

Users browsing this forum: frubem and 5 guests