Volume control disabled for both AY and PCM audio?

Bug reports and support area for Steem

Moderators: Mug UK, Steem Authors, Moderator Team

Forum rules
All bug reports must include:
Steem version
Host operating system version
TOS ROM version
Copy of steem.ini
Reference to or copy of disk image being used
Brief description of steps performed
Description of desired outcome
Description of actual outcome
Foebane
Atariator
Atariator
Posts: 21
Joined: Sat Jul 23, 2016 6:19 pm

Volume control disabled for both AY and PCM audio?

Postby Foebane » Tue Dec 27, 2016 8:53 pm

I've been trying out 3.9.0 and for the most part I am glad that all the clicks in the audio have disappeared, as well as lots of little improvements.

However, I tried this demo (http://www.pouet.net/prod.php?which=59066) and compared to the video of real hardware, the sections using both the STE PCM audio and the AY audio fail to fade out when they're meant to. Has this dual volume control been disabled or do I need to check a box in the Sound settings?

User avatar
Steven Seagal
Atari God
Atari God
Posts: 1950
Joined: Sun Dec 04, 2005 9:12 am
Location: Undisclosed
Contact:

Re: Volume control disabled for both AY and PCM audio?

Postby Steven Seagal » Tue Dec 27, 2016 9:32 pm

Alas, to remove the clicks I had to eliminate the "DSP" emulation of volume and fall back to old Steem, which means it doesn't effect PSG (AY) anymore, which I forgot. He he... :oops:

Could you indicate where/when it should fade?
There's a Microwire checkbox in Sound options but I'm afraid it won't help.

Foebane
Atariator
Atariator
Posts: 21
Joined: Sat Jul 23, 2016 6:19 pm

Re: Volume control disabled for both AY and PCM audio?

Postby Foebane » Tue Dec 27, 2016 10:08 pm

The fade-outs I'm referring to are in the video linked from "video" on the main demo link posted above.

These are the points in the video, which should match emulation closely:
00:40 Credits and robot voiceover
05:22 Last picture of hand-pixelled slideshow
07:45 End of digitised slideshow

I forgot to mention, that the STE PCM music parts still fade out, but the AY audio remains at full volume until the part ends and the next part loads.

I'm starting to wonder if the clicks are actually part of real ST hardware audio, as there's a few in that video.


Return to “Support”

Who is online

Users browsing this forum: No registered users and 1 guest