Page 1 of 1

Anyone getting bombs with Automation floppy disk emulation?

Posted: Fri Aug 04, 2017 7:09 pm
by Sowden
Hey guys. So I just got my wifi working recently, so I started downloading games through the floppy emulation software. I have downloaded about 10 or so zip files on my USB thumb drive. But every one I mounted would not load properly. I either get three to four bombs, with sometime getting a few more. It seems to bomb when it starts to unpack the game, when the screen flashes random different color stripes. I've tried unzipping the MSA files, converting them to ST files, I got the same result. Then I thought to get some of my archived game disk that uses the same process, same bomb situation. I then downloaded some Pompy Pirates on my USB thumb drive from my PC. I ran those games and they all seemed to load fine. If I have some more time tonight I will try to mess around with it some more. But has anyone else had problems like this? Thanks guys.

Re: Anyone getting bombs with Automation floppy disk emulation?

Posted: Sat Aug 05, 2017 7:47 am
by AtariZoll
Big %-age of cracks, menu disks is done very unprofessional, with dirty code, what easily fails on some other TOS version, with different RAM amount in machine than 'developer' had. And Automation was probably 'leader' in this :D
So, what TOS version, what Atari model you have ? How much RAM ?
Of course, it is possible too, that floppy emulation of CE is still not good enough. If you can, try those problematic images in some emulator - Steem, Hatari, where can set RAM size, using any TOS version - and then we will know better what is the real problem.

Re: Anyone getting bombs with Automation floppy disk emulation?

Posted: Sun Aug 06, 2017 4:22 pm
by Sowden
Ha ha ha, I didn't know there was any other way to do things but cleanly :) Well alright, I did some more testing and found some things. But first, here are some stats. I have a 1040STF with TOS 1.02 running. Not my original TOS, but I did some wiring to make the chips all work. As for my RAM I have 1024 available. I got system info and matched all of the stats from my real ST to Seem SSE. I loaded the same disks on the emulator and the Cosmosex and I was still getting the same results. The emulator was running it just fine and my real ST crashed. I should mention that some of the games that Cosmosex is crashing ran find on my HxC while I had it installed. But I did discover something. Since booting with the device plugged in, I have tried booting the A drive with and without CE running. Both gave me the same results. So I decided to try unplugging the ACSI plug in the back of my ST once I had the floppies mounted. I still had control of swapping the three floppy slots. Once I did that, the games loaded perfectly. They got past the unpacking stage and ran the program like it should. Do you think that even trying to load CE_DD would take up too much RAM on boot? Thats the only thing I can think of.