Data corruption on cosmos ex from share to cf partition

News, questions and bugs reports about CosmosEx by Jookie. Now we have a Raspberry Pi in our machines!

Moderators: Jookie, Moderator Team

alienkidmj12
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 118
Joined: Sat Mar 10, 2012 6:45 pm

Data corruption on cosmos ex from share to cf partition

Postby alienkidmj12 » Sun Dec 18, 2016 8:59 pm

I just received my cosmos ex and I'm experiencing corruption also when copying from share drive to local cf partition. For example when I unpack zip from share I get crc errors, when I copy files off i get read errors.

I've replaced scsi cable and also tried powering via USB. I have latest firmware update. This is a Falcon 030. I've tried version 9.2 and 10.01 of hddriver.

Still no luck

alienkidmj12
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 118
Joined: Sat Mar 10, 2012 6:45 pm

Re: Data corruption on cosmos ex from share to cf partition

Postby alienkidmj12 » Sun Dec 18, 2016 9:26 pm

The scsi cables I've tested were previously used for data transfer tests so I know they work fine.

User avatar
exxos
Hardware Guru
Hardware Guru
Posts: 4933
Joined: Fri Mar 28, 2003 8:36 pm
Location: England
Contact:

Re: Data corruption on cosmos ex from share to cf partition

Postby exxos » Sun Dec 18, 2016 9:53 pm

The falcon PSU once recapped is likely going to be the most stable source of power your gonna get. I have read SCSI issues are also a issue when the clock patch isn't fitted.

Making sure your firmware is up to date is a thing to also try, Jookie mentioned some issues a few days ago (Can't remember what now though). I would also make sure you get the latest HD driver software, I think someone mentioned some issues with V10 but was fixed in the current release (again can't remember what, I don't have a cosmo yet so don't pay much attention to those threads, but likely others will chime in with more info anyway).
4MB STFM 1.44 FD- VELOCE+ 020 STE - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - various clutter

http://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
http://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.
http://ataristeven.exxoshost.co.uk/Steem.htm Latest Steem Emulator

alienkidmj12
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 118
Joined: Sat Mar 10, 2012 6:45 pm

Re: Data corruption on cosmos ex from share to cf partition

Postby alienkidmj12 » Sun Dec 18, 2016 10:01 pm

Yes I have HD driver 10.1 now. Had to splash out today just for try it out lol. No luck though

alienkidmj12
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 118
Joined: Sat Mar 10, 2012 6:45 pm

Re: Data corruption on cosmos ex from share to cf partition

Postby alienkidmj12 » Sun Dec 18, 2016 10:03 pm

I'm sure the clock patch is there. As its next to the nvram chip. Has wires running off it. Unless it can go faulty. I very much doubt that's happened lol

User avatar
exxos
Hardware Guru
Hardware Guru
Posts: 4933
Joined: Fri Mar 28, 2003 8:36 pm
Location: England
Contact:

Re: Data corruption on cosmos ex from share to cf partition

Postby exxos » Sun Dec 18, 2016 10:05 pm

alienkidmj12 wrote:I'm sure the clock patch is there. As its next to the nvram chip. Has wires running off it. Unless it can go faulty. I very much doubt that's happened lol


The patch I designed or some other patch ? Theres a few versions of it. Some not so good in fact.
4MB STFM 1.44 FD- VELOCE+ 020 STE - Falcon 030 CT60 - Atari 2600 - Atari 7800 - Gigafile - SD Floppy Emulator - PeST - various clutter

http://www.exxoshost.co.uk/atari/ All my hardware guides - mods - games - STOS
http://www.exxoshost.co.uk/atari/last/storenew/ - All my hardware mods for sale - Please help support by making a purchase.
http://ataristeven.exxoshost.co.uk/Steem.htm Latest Steem Emulator

User avatar
Jookie
Hardware Guru
Hardware Guru
Posts: 1245
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia
Contact:

Re: Data corruption on cosmos ex from share to cf partition

Postby Jookie » Tue Dec 20, 2016 12:42 am

I'm not sure (although I guess) I'm talking to the same person through facebook, so I'll c&p here what I've written there, so we would have a public copy of the thing :)

I had an odd issue with it one time, that after start it didn't want to work, see this:
https://github.com/atarijookie/ce-atari/issues/99

So, run the test, see if it fails like before. Then connect to it using ssh, stop the linux app by running /ce/ce_stop.sh
...and then start the ce app again by running: /ce/ce_start.sh
then see if the test results are better or still bad.

Also: please check using 'top' or something similar if your system load is not high (using too much cpu %).

And it would be also nice to see if your linux boot is finished at that time - if you have a TV with HDMI around, connect it to HDMI of Raspberry Pi and see if the booting process finished, or still does something (like waiting for network or something).


Social Media

     

Return to “CosmosEx”

Who is online

Users browsing this forum: No registered users and 2 guests

cron