[SOLVED] Maybe HDDriver 10.0 doesn't work with CosmosEX v2

News, questions and bugs reports about CosmosEx by Jookie. Now we have a Raspberry Pi in our machines!

Moderators: Jookie, Moderator Team

User avatar
Estrayk
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 140
Joined: Mon Nov 23, 2015 2:52 pm
Location: Spain

[SOLVED] Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby Estrayk » Fri Dec 09, 2016 3:42 pm

Well, seems that last version of HDDriver doesn't work with CosmosEX.

I make the partitions, seems all is correct, but when I install HDDRIVER in C for boot. In the next reset Just show the first three partitions.

Video:

https://www.youtube.com/watch?v=7-C-SgGBKBI



my CosmosEX v2 config in ASCI MODE:

Image

Last edited by Estrayk on Sat Dec 10, 2016 4:23 pm, edited 1 time in total.
・Falcon 030+FPU 14mb CosmosEX・Atari MegaSTE 4Mb CosmosEX・Atari STe 4Mb GotekHxC+Satan・Amiga A600 Vampire V2・Amiga A1200 030/50・MIST・

nanard
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 107
Joined: Mon Apr 04, 2016 2:11 pm

Re: Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby nanard » Fri Dec 09, 2016 3:58 pm

well SDCard on CosmosEx should work just the same as UltraSatan...
4MB STE + CosmosEx /|\ MegaST4 + MegaFile 44

User avatar
Estrayk
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 140
Joined: Mon Nov 23, 2015 2:52 pm
Location: Spain

Re: Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby Estrayk » Fri Dec 09, 2016 7:38 pm

nanard wrote:well SDCard on CosmosEx should work just the same as UltraSatan...


well, with old HDDriver 8.x version works perfectly. With ICD Pro driver works perfectly. WIth PPera driver works more or less fine. But seems doesnt work with the new 10.0

Anyone test last 10.0 version with UltraSatan?
・Falcon 030+FPU 14mb CosmosEX・Atari MegaSTE 4Mb CosmosEX・Atari STe 4Mb GotekHxC+Satan・Amiga A600 Vampire V2・Amiga A1200 030/50・MIST・

crashman
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 138
Joined: Sat May 29, 2010 2:23 am
Location: Vilanova i la Geltrú - Barcelona
Contact:

Re: Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby crashman » Fri Dec 09, 2016 7:46 pm

with those partitions made by version 10, could you try top run ver 8, to see if the missing F reappears?
260ST, 520ST, 520ST+, 520STFM, 1040STE, 4160STE, STACY 2, MEGA ST, MEGA ST2, MEGA ST4, MEGA STE, TT030, FALCON030, FALCON030 with Centurbo 2rB, Firebee
SH204, Megafile 30, Megafile 60, Megafile 44
SM124, SM146, SC1224, SC1435
Satandisk, Ultrasatan, HxC SD, Hxc SD Slim, NetUSBee, CosmosEX, Unicorn, Gotek HxC
2600VCS, LYNX, LYNX II, JAGUAR

nanard
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 107
Joined: Mon Apr 04, 2016 2:11 pm

Re: Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby nanard » Fri Dec 09, 2016 7:50 pm

when you reboot, it doesn't detect the ICD extension :
https://youtu.be/7-C-SgGBKBI?t=3m9s

when double clicked on PRG it detects :
https://youtu.be/7-C-SgGBKBI?t=17s

It think that is the issue
Without ICD extension, disk size is limited to 1GB
4MB STE + CosmosEx /|\ MegaST4 + MegaFile 44

User avatar
Estrayk
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 140
Joined: Mon Nov 23, 2015 2:52 pm
Location: Spain

Re: Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby Estrayk » Fri Dec 09, 2016 11:42 pm

crashman wrote:with those partitions made by version 10, could you try top run ver 8, to see if the missing F reappears?


let me check

nanard wrote:when you reboot, it doesn't detect the ICD extension :
https://youtu.be/7-C-SgGBKBI?t=3m9s

when double clicked on PRG it detects :
https://youtu.be/7-C-SgGBKBI?t=17s

It think that is the issue
Without ICD extension, disk size is limited to 1GB


You´re right nanard!!! Yellow_Hot_Colorz_PDT_23 Yellow_Hot_Colorz_PDT_23
Thats the problem for sure!!!
I had not noticed. but... why? let me check somethings...
・Falcon 030+FPU 14mb CosmosEX・Atari MegaSTE 4Mb CosmosEX・Atari STe 4Mb GotekHxC+Satan・Amiga A600 Vampire V2・Amiga A1200 030/50・MIST・

nanard
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 107
Joined: Mon Apr 04, 2016 2:11 pm

Re: Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby nanard » Sat Dec 10, 2016 10:53 am

here are my test results : https://github.com/atarijookie/ce-atari/issues/104
I think you should contact Uwe Seimet about this bug. Or should I ? :)
4MB STE + CosmosEx /|\ MegaST4 + MegaFile 44

User avatar
Estrayk
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 140
Joined: Mon Nov 23, 2015 2:52 pm
Location: Spain

Re: Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby Estrayk » Sat Dec 10, 2016 11:20 am

nanard wrote:here are my test results : https://github.com/atarijookie/ce-atari/issues/104
I think you should contact Uwe Seimet about this bug. Or should I ? :)


Thank you very much for you interest nanard but, are you sure that isnt a CosmosEX bug?
・Falcon 030+FPU 14mb CosmosEX・Atari MegaSTE 4Mb CosmosEX・Atari STe 4Mb GotekHxC+Satan・Amiga A600 Vampire V2・Amiga A1200 030/50・MIST・

nanard
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 107
Joined: Mon Apr 04, 2016 2:11 pm

Re: Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby nanard » Sat Dec 10, 2016 11:30 am

that could be, we need to investigate, that's why the HDDriver author need to be contacted.
as far as I know, HDDriver 10.0 is the only driver with this "ICD extension detection bug"
and what's is very specific is that upon rescan it's working
4MB STE + CosmosEx /|\ MegaST4 + MegaFile 44

User avatar
Estrayk
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 140
Joined: Mon Nov 23, 2015 2:52 pm
Location: Spain

Re: Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby Estrayk » Sat Dec 10, 2016 12:17 pm

I´ve contacted with Uwe Seimet (HDDriver author) for this issue. Waiting for his reply.
・Falcon 030+FPU 14mb CosmosEX・Atari MegaSTE 4Mb CosmosEX・Atari STe 4Mb GotekHxC+Satan・Amiga A600 Vampire V2・Amiga A1200 030/50・MIST・

User avatar
Estrayk
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 140
Joined: Mon Nov 23, 2015 2:52 pm
Location: Spain

Re: [SOLVED] Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby Estrayk » Sat Dec 10, 2016 4:26 pm

Hello all.

Uwe Seimet (HDDriver author) know this bug and told me that he'll launch a new version 10.01 with the fix. So, you'll can use HDDriver 10.01 when it will be released. (very soon)

SOLVED thread.

Code: Select all

10.01
- HDDRIVER: Up to 15% higher IDE transfer rates compared to previous
  versions. (10.01)
- HDDRIVER: Faster byte-swapping. (10.01)
- HDDRIVER: Optimizations to reduce the memory footprint. (10.01)
- HDDRIVER: Fixed a problem in HDDRIVER 10.00 that affected the automatic
  detection of ICD compatible adapters. (10.01)
・Falcon 030+FPU 14mb CosmosEX・Atari MegaSTE 4Mb CosmosEX・Atari STe 4Mb GotekHxC+Satan・Amiga A600 Vampire V2・Amiga A1200 030/50・MIST・

crashman
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 138
Joined: Sat May 29, 2010 2:23 am
Location: Vilanova i la Geltrú - Barcelona
Contact:

Re: [SOLVED] Maybe HDDriver 10.0 doesn't work with CosmosEX v2

Postby crashman » Mon Dec 12, 2016 6:52 pm

And now HDDriver 10.01 is avalaible.

http://hddriver.seimet.de/en/news.html
260ST, 520ST, 520ST+, 520STFM, 1040STE, 4160STE, STACY 2, MEGA ST, MEGA ST2, MEGA ST4, MEGA STE, TT030, FALCON030, FALCON030 with Centurbo 2rB, Firebee
SH204, Megafile 30, Megafile 60, Megafile 44
SM124, SM146, SC1224, SC1435
Satandisk, Ultrasatan, HxC SD, Hxc SD Slim, NetUSBee, CosmosEX, Unicorn, Gotek HxC
2600VCS, LYNX, LYNX II, JAGUAR


Social Media

     

Return to “CosmosEx”

Who is online

Users browsing this forum: No registered users and 3 guests

cron