MP3 playing on STE - Decoding through the CosmosEx

News, questions and bugs reports about CosmosEx by Jookie. Now we have a Raspberry Pi in our machines!

Moderators: Jookie, Moderator Team

nanard
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 107
Joined: Mon Apr 04, 2016 2:11 pm

Re: MP3 playing on STE - Decoding through the CosmosEx

Postby nanard » Mon May 02, 2016 10:00 pm

I made some test usng the YM2149 : https://github.com/miniupnp/AtariST/tre ... r/ym_digit
My routine is not optimized enough. As you are talking about, there are a few tricks to implement higher sample rates
4MB STE + CosmosEx /|\ MegaST4 + MegaFile 44

nanard
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 107
Joined: Mon Apr 04, 2016 2:11 pm

Re: MP3 playing on STE - Decoding through the CosmosEx

Postby nanard » Thu May 05, 2016 4:24 pm

@leonard: I'm setting all YM regs to 0 before starting (only setting reg #7 to %11111111) is that the proper init ?
https://github.com/miniupnp/AtariST/blo ... lay.s#L573
4MB STE + CosmosEx /|\ MegaST4 + MegaFile 44

User avatar
leonard
Moderator
Moderator
Posts: 640
Joined: Thu May 23, 2002 10:48 pm
Contact:

Re: MP3 playing on STE - Decoding through the CosmosEx

Postby leonard » Fri May 20, 2016 2:12 pm

nanard wrote:is that the proper init ?


yes, but you should not change bit 6 & 7 of register 7 to keep best compatibility ( not related to sound )

reg7 = (reg7 & 0xc0) | 0x3f;
Leonard/OXYGENE.


Social Media

     

Return to “CosmosEx”

Who is online

Users browsing this forum: No registered users and 1 guest