I think my MiST's SD reader is starting to fail

https://github.com/mist-devel/mist-board/wiki

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

NML32
Captain Atari
Captain Atari
Posts: 321
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

I think my MiST's SD reader is starting to fail

Postby NML32 » Sat Mar 04, 2017 9:01 pm

Lately, my MiST has been having issues reading all my SD cards on boot new and old I have to power cycle and remove and reinsert the cards many times before they are read.

When I turn on the MiST most of the time the red light just blinks and doesn't read the SD card and it's a lengthy process of turning on and off the MiST and ejecting and reinserting the sd card until it's read.

Has anyone else experienced this with their MiST? Any suggestions on what I can try to resolve this before I decide to buy a replacement MiST?

Thanks

User avatar
Newsdee
Atari Super Hero
Atari Super Hero
Posts: 932
Joined: Fri Sep 19, 2014 8:40 am

Re: I think my MiST's SD reader is starting to fail

Postby Newsdee » Sun Mar 05, 2017 1:37 am

Mine still works but the spring broke meaning the cards won't eject any more. Luckily they stick out enough that I can remove it without much problem.

User avatar
farvardin
Captain Atari
Captain Atari
Posts: 343
Joined: Fri Jan 01, 2010 5:50 pm
Location: France
Contact:

Re: I think my MiST's SD reader is starting to fail

Postby farvardin » Sun Mar 05, 2017 6:53 am

Can't you just solder a new reader instead of buying a new mist?

User avatar
xc8
Captain Atari
Captain Atari
Posts: 193
Joined: Mon Aug 11, 2008 5:23 pm
Location: B'ham, UK

Re: I think my MiST's SD reader is starting to fail

Postby xc8 » Sun Mar 05, 2017 10:54 am

NML32 wrote:Lately, my MiST has been having issues reading all my SD cards on boot new and old I have to power cycle and remove and reinsert the cards many times before they are read.

When I turn on the MiST most of the time the red light just blinks and doesn't read the SD card and it's a lengthy process of turning on and off the MiST and ejecting and reinserting the sd card until it's read.

Has anyone else experienced this with their MiST? Any suggestions on what I can try to resolve this before I decide to buy a replacement MiST?

Thanks


dirty contacts maybe, try to clean the SD's contacts, use a pen eraser, or apply some contact spray (servisol 10, Kontakt 60 etc) via a cotton bud on the contacts of an SD card, then re-insert a couple of times to clean too the contacts of the SD socket

NML32
Captain Atari
Captain Atari
Posts: 321
Joined: Tue Mar 11, 2014 1:54 am
Location: USA/Florida

Re: I think my MiST's SD reader is starting to fail

Postby NML32 » Sun Mar 05, 2017 1:21 pm

I've tried cleaning the contacts on the SD card and there weren't any improvements next I'll open up the MiST and see if I can clean the reader's contacts. I'm not very good at soldering so with my luck I'd probably make things worse.

Update: After opening the case I applied slight pressure to the top of the SD card reader and now the MiST is reading all my SD cards on the first insert.

DanyPPC
Atari freak
Atari freak
Posts: 63
Joined: Tue Feb 21, 2017 7:02 am

Re: I think my MiST's SD reader is starting to fail

Postby DanyPPC » Sun Mar 05, 2017 7:04 pm

Good !


Return to “MiST”

Who is online

Users browsing this forum: No registered users and 0 guests

cron