SV FW rev 10 and new Svethlana driver

News, Support and Development discussions relating to SuperVidel.

Moderators: Mug UK, moondog/.tSCc., [ProToS], lp, instream, Moderator Team, Nature

instream
Nature
Nature
Posts: 165
Joined: Mon Aug 03, 2009 9:08 am
Location: Göteborg, Sweden
Contact:

SV FW rev 10 and new Svethlana driver

Postby instream » Wed Apr 27, 2016 10:16 am

Hi all! :)

Yesterday evening we put a new SV firmware at nature.atari.org, rev 10. The big news in it is that the svethlana ethernet MAC controller is now connected using DMA to the DDR2 RAM. The MAC used to have its own four packet buffers in FPGA BRAM instead, just two buffers for TX and two for RX. With the DMA connection we can now have 64 buffers in each direction, which is the max that the MAC controller supports. This gives us a great speed increase when doing test downloads of data. With 2+2 buffers we used to get approx 70KB/s, but now we get approx 1.5MB/s! :D This is the test that we run:

wget -O /dev/null http://cachefly.cachefly.net/100mb.test

The FW is available as Ziped MCS-files for you with JTAG-cables, and as our own SV updater program, with the new FW built in. Note that you must use the new Svethlana driver, svethd64.xif, together with the new FW rev 10. The old driver will not work with the new FW, and the new driver will not work with older FW than rev 10. The Svethlana driver was compiled for Mint 1.17.0, and we have indications that the same driver doesn't work on newer Mint versions. We will put the source code on our homepage soon so the Mint team can include it in their repository.

patjomki
Atari freak
Atari freak
Posts: 53
Joined: Fri Mar 09, 2007 11:34 pm

Re: SV FW rev 10 and new Svethlana driver

Postby patjomki » Sat May 07, 2016 10:51 am

instream wrote:Hi all! :)

Yesterday evening we put a new SV firmware at nature.atari.org, rev 10.


Thanks for the new firmware. Great news.

One question: What's the speed of svethlana with the new drivers compared to ethernat now?

Edit: Did the above mentioned test on my machine with ethernat. Got approx. 600k/sec. Hmm, seems it is time to install svethlana now.

User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1023
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: SV FW rev 10 and new Svethlana driver

Postby TheNameOfTheGame » Sat May 07, 2016 4:15 pm

Thank you!

instream
Nature
Nature
Posts: 165
Joined: Mon Aug 03, 2009 9:08 am
Location: Göteborg, Sweden
Contact:

Re: SV FW rev 10 and new Svethlana driver

Postby instream » Tue May 10, 2016 8:29 pm

patjomki wrote:
instream wrote:Hi all! :)

Yesterday evening we put a new SV firmware at nature.atari.org, rev 10.


Thanks for the new firmware. Great news.

One question: What's the speed of svethlana with the new drivers compared to ethernat now?

Edit: Did the above mentioned test on my machine with ethernat. Got approx. 600k/sec. Hmm, seems it is time to install svethlana now.

Yes, I forgot to mention that the Ethernat also has only four packet buffers, two in each direction. But this is its maximum, because of how the ethernet MAC+PHY chip 91C111 is designed. I'm surprised that you got as high as 600KB/s on the ethernat, but maybe you're just much closer to the test server. :)

patjomki
Atari freak
Atari freak
Posts: 53
Joined: Fri Mar 09, 2007 11:34 pm

Re: SV FW rev 10 and new Svethlana driver

Postby patjomki » Wed Jun 22, 2016 6:42 am

instream wrote:Yes, I forgot to mention that the Ethernat also has only four packet buffers, two in each direction. But this is its maximum, because of how the ethernet MAC+PHY chip 91C111 is designed. I'm surprised that you got as high as 600KB/s on the ethernat, but maybe you're just much closer to the test server. :)


I just recently installed svethlana. With the latest SV firmware I get a transfer rate of 1.52MB/s compared to 115k/s with the old firmware. Transfer rates with EtherNat are still the same. :)

And I can confirm that svethlana drivers are working with the latest (current) MiNT not only 1.17.

User avatar
Beetle
Atari freak
Atari freak
Posts: 72
Joined: Sat Jan 26, 2008 10:09 pm
Contact:

Re: SV FW rev 10 and new Svethlana driver

Postby Beetle » Mon Jul 04, 2016 10:49 am

Hi there,

after patjomki's post i also tried once more my SVEthLanA. Again, i cannot get it to work at all.
I susupect that i can install driver correctly, and able to setup MiNTNet too, since my EtherNat works.

Therefore either my SVeTHLanA or SuperVidel has a fault. :-(
What Atari do you want to modify today?

mikro
Atari God
Atari God
Posts: 1263
Joined: Sat Sep 10, 2005 11:11 am
Location: Brisbane, Queensland, Australia
Contact:

Re: SV FW rev 10 and new Svethlana driver

Postby mikro » Mon Sep 05, 2016 10:08 am

instream wrote:This gives us a great speed increase when doing test downloads of data. With 2+2 buffers we used to get approx 70KB/s, but now we get approx 1.5MB/s! :D

This can't be right -- I haven't updated my FW at least since March 2016 and I could reach >1 MB/s without any problem. Too bad I can't compare, my CT60+SV Falcon is in Europe. :-/

instream
Nature
Nature
Posts: 165
Joined: Mon Aug 03, 2009 9:08 am
Location: Göteborg, Sweden
Contact:

Re: SV FW rev 10 and new Svethlana driver

Postby instream » Fri Sep 09, 2016 9:06 pm

Then you must have tested against a local server with very low ping time. The mentioned 70KB/s was against the remote server mentioned in the first post.

Rustynutt
Captain Atari
Captain Atari
Posts: 358
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon
Contact:

Re: SV FW rev 10 and new Svethlana driver

Postby Rustynutt » Mon Apr 03, 2017 12:50 am

Dumb question :) What section of nature.atari.org are files stored in? I found it once via a link, but so far can only access the old home page.

instream
Nature
Nature
Posts: 165
Joined: Mon Aug 03, 2009 9:08 am
Location: Göteborg, Sweden
Contact:

Re: SV FW rev 10 and new Svethlana driver

Postby instream » Mon Apr 03, 2017 10:38 am

Files are stored on our own server at hencox.gildaelectronics.se. If you can't see the list of files or suspect that it is too old, right click on the frame that holds the actual list of files and select "Reload frame". Not sure this is the exact phrase since my current browser is not in english.

mikro
Atari God
Atari God
Posts: 1263
Joined: Sat Sep 10, 2005 11:11 am
Location: Brisbane, Queensland, Australia
Contact:

Re: SV FW rev 10 and new Svethlana driver

Postby mikro » Mon Apr 03, 2017 10:27 pm

instream wrote:Note that you must use the new Svethlana driver, svethd64.xif, together with the new FW rev 10. The old driver will not work with the new FW, and the new driver will not work with older FW than rev 10. The Svethlana driver was compiled for Mint 1.17.0, and we have indications that the same driver doesn't work on newer Mint versions. We will put the source code on our homepage soon so the Mint team can include it in their repository.

While reading this I've realised: how to distinguish those two? Someone has finally integrated your source code into the freemint tree (pending): https://github.com/freemint/freemint/pull/30 but how do we know for which FW? Is there a way to switch between them?

EDIT: judging from your website it would seem the source code is for >= FW10.

Rustynutt
Captain Atari
Captain Atari
Posts: 358
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon
Contact:

Re: SV FW rev 10 and new Svethlana driver

Postby Rustynutt » Tue Apr 04, 2017 8:55 am

instream wrote:Files are stored on our own server at hencox.gildaelectronics.se. If you can't see the list of files or suspect that it is too old, right click on the frame that holds the actual list of files and select "Reload frame". Not sure this is the exact phrase since my current browser is not in english.


(btw, tried the .se site, got access forbidden message.).
Thanks, i was going to nature.atari.org. NetSurf didn't see the "downloads" menu.
Thanks! You shipped the SV it seems years ago :) Actually tried talking me into two, said the wife would have a fit. Bought a complete Falcon with one, and the one I have from you guys. Guess I'll have to go back to the NOVA ATI setup on the other Falcon :) Finally toying with the CT60 Rodolphe shipped in 2003 with a Xylinx cable/box. It has boot loader V.9...Guess I need to update :oops: Least now I can look back on all the mistakes :wink: :wink:


Social Media

     

Return to “SuperVidel”

Who is online

Users browsing this forum: No registered users and 1 guest