Svethlana and Easymint (Mint 1.18.0)???

News, Support and Development discussions relating to SuperVidel.

Moderators: Mug UK, moondog/.tSCc., [ProToS], lp, instream, Moderator Team, Nature

User avatar
MacFalcon
Captain Atari
Captain Atari
Posts: 255
Joined: Sat Oct 11, 2003 1:00 pm
Location: Muenchberg, Germany
Contact:

Svethlana and Easymint (Mint 1.18.0)???

Postby MacFalcon » Tue Apr 22, 2014 3:55 pm

Hello,

After I finally installed my supervidel hardwarewise and it worked like a charm under TOS, I now did install the svethlana and easymint. I used latest easymint what gave me mint 1.18 and latest driver from nature homepage. I have no networking, neither with DHCP nor with manual configuration. With dhcp I won´t get an IP, with manual config I cannot do any networkung... But the svethlana seems to be there and when I try to ping my router the svethlana led will start blinking... But more I cannot do...

Any suggestions?

Best regards,

Chris
Falcon060, 100/25 MHz, 256 MB SD-RAM, PhantomPBS, CTPCI with Radeon, USB and Network Card. atari rulez!

User avatar
calimero
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2047
Joined: Thu Sep 15, 2005 10:01 am
Location: STara Pazova, Serbia
Contact:

Re: Svethlana and Easymint (Mint 1.18.0)???

Postby calimero » Wed Jun 18, 2014 7:06 pm

Hi,
I have opposite problem: Svethlana work in MiNT but not in plain TOS! :D

check what driver you use in MiNT. I use:
ETHERNAT.XIF 6847 bytes in MiNT\XIF folder (it works fine)


and for plain TOS:
ENEC6.STX 5433 in STING folder - but it wont work! :(
using Atari since 1986.http://wet.atari.orghttp://milan.kovac.cc/atari/software/ ・ Atari Falcon030/CT63/SV ・ Atari STe ・ Atari Mega4/MegaFile30/SM124 ・ Amiga 1200/PPC ・ Amiga 500 ・ C64 ・ ZX Spectrum ・ RPi ・ MagiC! ・ MiNT 1.18 ・ OS X

instream
Nature
Nature
Posts: 165
Joined: Mon Aug 03, 2009 9:08 am
Location: Göteborg, Sweden
Contact:

Re: Svethlana and Easymint (Mint 1.18.0)???

Postby instream » Thu Jun 19, 2014 9:35 am

calimero wrote:Hi,
I have opposite problem: Svethlana work in MiNT but not in plain TOS! :D

check what driver you use in MiNT. I use:
ETHERNAT.XIF 6847 bytes in MiNT\XIF folder (it works fine)


and for plain TOS:
ENEC6.STX 5433 in STING folder - but it wont work! :(

The Ethernat XIF has nothing to do with the Svethlana. You must have renamed the Svethlana XIF file to make that work. :wink:
And no driver exists for Sting/TOS for the Svethlana. Looks like you are trying to use an ethernec driver. It has nothing to do with the Svethlana either. :wink:

User avatar
calimero
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2047
Joined: Thu Sep 15, 2005 10:01 am
Location: STara Pazova, Serbia
Contact:

Re: Svethlana and Easymint (Mint 1.18.0)???

Postby calimero » Thu Jun 19, 2014 9:43 am

instream wrote:
calimero wrote:Hi,
I have opposite problem: Svethlana work in MiNT but not in plain TOS! :D

check what driver you use in MiNT. I use:
ETHERNAT.XIF 6847 bytes in MiNT\XIF folder (it works fine)


and for plain TOS:
ENEC6.STX 5433 in STING folder - but it wont work! :(

The Ethernat XIF has nothing to do with the Svethlana. You must have renamed the Svethlana XIF file to make that work. :wink:
And no driver exists for Sting/TOS for the Svethlana. Looks like you are trying to use an ethernec driver. It has nothing to do with the Svethlana either. :wink:

lol!
and still, svethlana works in my MiNT setup... :) I forgot how I do install it, maybe somewhere else I have right driver :) (I use before NetUSbee for LAN...)

regarding Sting: are there any plans in future to support Sting?
using Atari since 1986.http://wet.atari.orghttp://milan.kovac.cc/atari/software/ ・ Atari Falcon030/CT63/SV ・ Atari STe ・ Atari Mega4/MegaFile30/SM124 ・ Amiga 1200/PPC ・ Amiga 500 ・ C64 ・ ZX Spectrum ・ RPi ・ MagiC! ・ MiNT 1.18 ・ OS X

User avatar
MacFalcon
Captain Atari
Captain Atari
Posts: 255
Joined: Sat Oct 11, 2003 1:00 pm
Location: Muenchberg, Germany
Contact:

Re: Svethlana and Easymint (Mint 1.18.0)???

Postby MacFalcon » Thu Dec 24, 2015 11:42 am

Okay, I now have that error again with mint 1.19... With 1.16 svethlana worked fine... Any suggestions?

Merry Christmas anyway!

Chris
Falcon060, 100/25 MHz, 256 MB SD-RAM, PhantomPBS, CTPCI with Radeon, USB and Network Card. atari rulez!

instream
Nature
Nature
Posts: 165
Joined: Mon Aug 03, 2009 9:08 am
Location: Göteborg, Sweden
Contact:

Re: Svethlana and Easymint (Mint 1.18.0)???

Postby instream » Fri Jan 01, 2016 4:10 pm

There must be some API change then in the XIF interface from 1.16/1.17 (under 1.17 the old svethlana.xif works fine for me) and 1.18/1.19. A recompilation of the freemint code package to get a new svethlana.xif might be needed. There are others on this forum who have much greater knowledge of the freemint and XIF source code tree than I have.

User avatar
MacFalcon
Captain Atari
Captain Atari
Posts: 255
Joined: Sat Oct 11, 2003 1:00 pm
Location: Muenchberg, Germany
Contact:

Re: Svethlana and Easymint (Mint 1.18.0)???

Postby MacFalcon » Thu Jan 07, 2016 11:23 pm

Maybe I should try posting this to the mint mailing list...

Best regards and thanks for the reply!

Chris
Falcon060, 100/25 MHz, 256 MB SD-RAM, PhantomPBS, CTPCI with Radeon, USB and Network Card. atari rulez!


Social Media

     

Return to “SuperVidel”

Who is online

Users browsing this forum: No registered users and 1 guest

cron