Punish Your Machine

All about ST/STE demos

Moderators: Mug UK, lotek_style, Moderator Team

User avatar
bod/STAX
Atari Super Hero
Atari Super Hero
Posts: 508
Joined: Wed Nov 24, 2004 8:13 pm
Location: Halesowen, West Midlands, England

Punish Your Machine

Postby bod/STAX » Thu Sep 14, 2006 2:52 pm

OK, this is really starting to p*ss me off now. :x

The very first time I downloaded Saint and tried PYM demo everything worked fine. I've since had to reinstall windows and now PYM just won't work in Saint (screen just repeatedly fades to black). I've tried various TOS versions from the bonus STNICCC cd-rom and memory configs, but to no avail.

I really want to run the 'Let's do the Twist Again' screen as I only have an STE.

Any help would be very much appreciated.

User avatar
Mug UK
Administrator
Administrator
Posts: 11422
Joined: Thu Apr 29, 2004 7:16 pm
Location: Stockport (UK)
Contact:

Postby Mug UK » Thu Sep 14, 2006 2:57 pm

What version of STEEM you running?

Also isn't there a "patched" version of PYM to get it working on emulators?
My main site: http://www.mug-uk.co.uk - slowly digging up the bits from my past (and re-working a few): Atari ST, Sega 8-bit (game hacks) and NDS (Music ripping guide).

I develop a free Word (for Windows) add-in that's available for Word 2007 upwards. It's a fix-it toolbox that will allow power Word users to fix document errors. You can find it at: http://www.mikestoolbox.co.uk

User avatar
unseenmenace
Atari God
Atari God
Posts: 1961
Joined: Tue Sep 21, 2004 9:33 pm
Location: Margate, Kent, UK
Contact:

Postby unseenmenace » Thu Sep 14, 2006 3:08 pm

He's using SainT but it may be worth trying STeem or an older version of SainT in case Leonard broke the compatibility with PYM in an update. I know it works on one of them as I pointed out to Leonard that the "Best Part Of Creation" screen didn't work and he managed to fix it.
UNSEEN MENACE
Several STFM's, 4MB STE, 2MB TT with 1.2GB Hard Drive and 14MB Falcon with 540MB Hard Drive,
Lynx 2 and Jaguar with JagCD
Member of GamebaseST and AtariLegend team
Check out my website at http://unseenmenace.110mb.com

User avatar
bod/STAX
Atari Super Hero
Atari Super Hero
Posts: 508
Joined: Wed Nov 24, 2004 8:13 pm
Location: Halesowen, West Midlands, England

Postby bod/STAX » Thu Sep 14, 2006 5:50 pm

It works under STEem, but the one screen I want to watch doesn't work on STE machines.

I've just tried version 1.99b with no luck, 1.85 tries to run the demo and the emulator just quits and 1.10 does the same as the latest version.

Incidentally the version of PYM is the one from the No Fragments disk.

Also the original Dark Side of the Spoon fails to work also because of Delta Force protection, so I have to use the patched version.

User avatar
Brume
Red eyes
Red eyes
Posts: 4185
Joined: Mon Apr 22, 2002 10:16 am
Location: France
Contact:

Postby Brume » Thu Sep 14, 2006 6:37 pm

I'm just coming to run the patched version of PYM and it works perfectly under SainT... which version did you try?

User avatar
unseenmenace
Atari God
Atari God
Posts: 1961
Joined: Tue Sep 21, 2004 9:33 pm
Location: Margate, Kent, UK
Contact:

Postby unseenmenace » Thu Sep 14, 2006 6:39 pm

I just tried the one I have on Saint 1.99b with TOS 1.4 and it worked fine.

Also works on 1.99g
You do not have the required permissions to view the files attached to this post.
UNSEEN MENACE
Several STFM's, 4MB STE, 2MB TT with 1.2GB Hard Drive and 14MB Falcon with 540MB Hard Drive,
Lynx 2 and Jaguar with JagCD
Member of GamebaseST and AtariLegend team
Check out my website at http://unseenmenace.110mb.com

User avatar
bod/STAX
Atari Super Hero
Atari Super Hero
Posts: 508
Joined: Wed Nov 24, 2004 8:13 pm
Location: Halesowen, West Midlands, England

Postby bod/STAX » Wed Sep 20, 2006 10:46 am

Thank you very much. :D

User avatar
leonard
Moderator
Moderator
Posts: 658
Joined: Thu May 23, 2002 10:48 pm
Contact:

Postby leonard » Tue Sep 26, 2006 9:47 am

oh yes the PYM protection code may won't work anymore in new version (shame on me). The "patched" version should work. Humm, it means that "dark side of the spoon" original disk mail fail because of the protection too. (both demos use the same protection by DeltaForce).

I wish have many spare tilme to fix all these nasty prefetching timing bugs... :-)
Leonard/OXYGENE.

User avatar
leonard
Moderator
Moderator
Posts: 658
Joined: Thu May 23, 2002 10:48 pm
Contact:

Postby leonard » Tue Sep 26, 2006 9:52 am

correction!! I just checked the latest SainT (v1.99g) and original disk (with protection) is just working well.

You can see the St-Cnx screen ! (great screen featuring all "SainT" power :-) great sound, great 4bit scroller :-))
Leonard/OXYGENE.

User avatar
MiggyMog
Atari Super Hero
Atari Super Hero
Posts: 866
Joined: Sun Oct 30, 2005 4:43 pm
Location: Scotland

Postby MiggyMog » Tue Sep 26, 2006 7:25 pm

That doesn't even work on my real ST!

I remember I had to go round to a friends house and use his STFM as I had just 'Upgraded' to the STE.
('< o o o o |''| STM,2xSTFM,2xSTE+HD,C-Lab Falcon MK2+HD,Satandisk,Ultrasatandisk,Ethernat.

User avatar
alien
Atari maniac
Atari maniac
Posts: 95
Joined: Sat May 01, 2004 4:01 am
Location: USA
Contact:

Postby alien » Tue Oct 24, 2006 6:11 pm

MiggyMog wrote:That doesn't even work on my real ST!

I remember I had to go round to a friends house and use his STFM as I had just 'Upgraded' to the STE.


STE is not ST. FWIW I had an STE in my hands for 2 hours & I tried to make it work with people talking all around me (not ideal). I almost got it working and then the guy had to leave, that's why there's no STE version... :(

Nevertheless, it's cool people still want to see it.
Alien / ST-Connexion


Social Media

     

Return to “Demos - General”

Who is online

Users browsing this forum: No registered users and 5 guests