Search found 642 matches

by leonard
Mon Jan 04, 2016 11:11 am
Forum: News & Announcements
Topic: "We Were @" hardware demo survey
Replies: 14
Views: 6129

Re: "We Were @" hardware demo survey

Great work for this amazing STE demo! It works like a charm on my 4 MB STE, with disk images loaded from HxC Floppy or CosmosEx. There are some problems with the 16 first pixels in the left border though, for example in the "Try to beat dis(tortion)" screen (however you mentioned this poi...
by leonard
Mon Dec 28, 2015 5:14 pm
Forum: Hardware
Topic: Internal power supply compatibility
Replies: 1
Views: 929

Internal power supply compatibility

Hi, I have a ATARI STE ( 4MiB ), and my internal power supply is really weird: my STE switch off automatically quite often. To switch it on again, I have to "press" the power supply metal casing a bit! (gasp) A friend of mine will trash its 520 STF. question: do you know if the power suppl...
by leonard
Sun Dec 27, 2015 5:35 pm
Forum: Coding
Topic: ATARI HDD low level info
Replies: 47
Views: 16283

Re: ATARI HDD low level info

@alien: this was exactly my first idea: geting the list of sectors of the two MSA files ( parsing FAT or using GEMDOS as you suggest but I don't know if GEMDOS offers such a functionality). I'm pretty sure low level HDD cluster reading is not so complex. All your message regarding HDD driver / cache...
by leonard
Sun Dec 27, 2015 11:58 am
Forum: Coding
Topic: ATARI HDD low level info
Replies: 47
Views: 16283

Re: ATARI HDD low level info

I think I can go like that: GGN told me it's safe to keep using GEMDOS file system if I use only memory at $10000 and more. So I will review the memory layout of the demo,I have plenty of room in the 4MB version. I think I'll keep $8 to $10000 for system. My kernel will go from $1000 to top of memor...
by leonard
Sat Dec 26, 2015 2:02 pm
Forum: Coding
Topic: ATARI HDD low level info
Replies: 47
Views: 16283

Re: ATARI HDD low level info

oh to be precise, "We Were @" could run on 2MB machine with music, but need 4MB only to cache unpacked floppy data in order to keep the demo flow. The kernel use low memory, and it's not compatible with system. But GGN gives me an idea I could use: backup low memory in upper memory so I ca...
by leonard
Sat Dec 26, 2015 1:15 pm
Forum: Coding
Topic: ATARI HDD low level info
Replies: 47
Views: 16283

ATARI HDD low level info

Hi, I'm thinking about an HDD version of "We Were @" demo. I want to do exactly the same trick I did for the HDD version of my Amiga Demo 2: keep the two MSA files, and put a small EXE you can run from HDD. In AMIGA Demo 2 I used upper memory to cache the complete MSA packed file, but in W...
by leonard
Sat Dec 26, 2015 12:45 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

Btw, in your code changes above, I assume you changed the other timings as well making sure the left border removal code is at the same cycle in both examples. Oh yes, the move.w opening the left border is executed at the same cycle in both exemple! Ok I understand everything now: the compo machine...
by leonard
Sat Dec 26, 2015 12:17 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

No, and to be clear, the screenshot is with large display mode (413 pixel wide). I see the little border on every part of We Were on my real STE + CRT, as usual for this trick (like MOLZ). The border is either black or raster (colour 0), between 14 and 16 pixels. It could depend on the STE model, o...
by leonard
Fri Dec 25, 2015 8:30 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

I surely miss something but are you agree only that mega-dist screen show the left margin right? Every other fullscreen in "We Were @" correctly display 416 pixels without any left margin, right? They all use 224 bytes lines. Add to this, I see the margin on the compo machine, I never saw ...
by leonard
Fri Dec 25, 2015 4:51 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

Steven: no I mean using HSCROLL with a different value for each scanline. If you use only 8265 one time a frame, everything is working ok, even on compo machine ( We Were use a lot of HSCROLL for complete screen and it works) 8265 has really strange behavior if used several times during the frame (i...
by leonard
Thu Dec 24, 2015 4:57 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

new information: my second try (the second image above) keep 12 or 16 pixels margin ( filled with color 0 ) on STNICCC compo or Wietze machine. I asked Wietze to test the SommarHack 2010 invtro by DHS. This intro use pixel scrolling per line + fullscreen. On his machine, the intro has exactly the sa...
by leonard
Thu Dec 24, 2015 1:55 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

Hi Troed

You think the compo machine could work "sometimes" ? Strange thing is that it always fail on Wietze machine
by leonard
Thu Dec 24, 2015 12:07 am
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

Ok new informations. Many thanks to Wietze for testing version I sent him on his STE (wich has the same issue as compo machine). I attached two of Wietze's shot, the first one is the We Were original with: movep.l d7,-5(a5) ; set screen ad in 8205, 8207, 8209 and dummy write in 820b ( D7=screen<<8) ...
by leonard
Wed Dec 23, 2015 11:56 pm
Forum: News & Announcements
Topic: "We Were @" hardware demo survey
Replies: 14
Views: 6129

Re: "We Were @" hardware demo survey

Frank B wrote:Lovely :) Nice to see some heavy blitter abuse in a demo :)


Hi Frank, I know you were one of the only blitter fan on that forum :) Now we're two :) I use blitter in almost every screens in "We Were @" demo.
by leonard
Wed Dec 23, 2015 11:27 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

I'm still using 8265=1 when yellow squares are filling the screen
by leonard
Wed Dec 23, 2015 10:57 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

thanks alien / nicolas for details about 8264, seems really a strange register (the fact that ATARI does not document it officially is really weird) And yes, I setup the video register each line. To be complete, my line is: movep.l d7,-5(a5) ; set screen ad in 8205, 8207, 8209 and dummy write in 820...
by leonard
Wed Dec 23, 2015 9:29 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

I have some important new informations: At first I though the left border was not open, but it is! by carefully looking the video of STNICCC demo competition during the megadistorter, I can see the left border is open, BUT there is 16 pixels missing. Exactly as a fullscreen picture was shifted 16 pi...
by leonard
Wed Dec 23, 2015 8:31 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

Re: STE specific fullscreen issue

yes you get the point! I don't have hardware to test. I even don't know that there was 8264 without prefetch :) Could you elaborate on this? Is this documented or already used in any practical code?
by leonard
Wed Dec 23, 2015 4:27 pm
Forum: 680x0
Topic: STE specific fullscreen issue
Replies: 34
Views: 11724

STE specific fullscreen issue

Hi all, I discovered at STNICCC that my mega-distorter screen in the "We Were @" does not open the left border on the compo machine. It works on many STE but that one. Another people reported me the same trouble. As I know there is many fullscreen or ST hardware gurus here, I open the subj...
by leonard
Wed Dec 23, 2015 4:11 pm
Forum: Coding
Topic: horizontal scrolling on ST
Replies: 569
Views: 139645

Re: horizontal scrolling on ST

Here's another recording with some of the people answering and asking questions in frame. Would be probably nice to annotate who's who. http://www.youtube.com/watch?v=xMij99FVDtA At 1:01:00 in the video above, Erik Simon ( famous "ES of TEX" ) made an intervention full of historical infor...
by leonard
Tue Dec 22, 2015 11:06 pm
Forum: News & Announcements
Topic: "We Were @" hardware demo survey
Replies: 14
Views: 6129

"We Were @" hardware demo survey

Hi everyone, before working on the final version of "We Were @", I need some infos. If you're an ATARI STE owner, please fill that survey https://docs.google.com/forms/d/1Cel1ZNz5QPARQIOkJXuGgkBu6JaHSR26-n7pMl2vBKM/viewform?usp=send_form Thanks! PS: "We Were @" STE demo party ver...
by leonard
Sat Dec 12, 2015 2:36 pm
Forum: News & Announcements
Topic: SainT emulator v2.40 is out!
Replies: 6
Views: 5561

SainT emulator v2.40 is out!

Hi,

SainT is not dead :) v2.40 is out. Now color write with blitter is working, and a lot a new things. More info in the package:

http://leonard.oxg.free.fr/

With CRT monitor gfx emulation and floppy drive sound, this is the best Demo Watcher you ever seen :)
by leonard
Sun Oct 25, 2015 10:36 pm
Forum: Demos - General
Topic: Mega Demos with Auto Mode
Replies: 5
Views: 15166

Re: Mega Demos with Auto Mode

Marcer wrote:anybody else recall?


I added a demo mode like cuddly in Nostalgic-O-Demo too. Just wait a while during the first introduction screen, or just press "d" key during the menu. In demo mode, all screens runs for 30 seconds and chain with others
by leonard
Sat Aug 29, 2015 8:55 am
Forum: Demos
Topic: little Blitter benchmark demo
Replies: 89
Views: 46459

Re: little Blitter benchmark demo

Possibly but we're comparing general purpose code against demo code ;) I bet there is some serious cheating going on I agreee we compare two things very different. But my point is you already compare BLITTER generic code with PRE-SHIFT CPU routine. To me "preshift" is already not so "...
by leonard
Fri Aug 28, 2015 4:17 pm
Forum: Demos
Topic: little Blitter benchmark demo
Replies: 89
Views: 46459

Re: little Blitter benchmark demo

I must say that I find this best compatibility with TOS 1.00 little strange. Will not continue list of drawbacks :D I totally agree with you. My bad for those TOS incompatibility in SainT. The main problem is that I never really investigate to fix TOS emulation problems I'm focused on making demos ...

Go to advanced search