Search found 56 matches

by foft
Fri Jul 19, 2019 8:49 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

Fixed the drive issue: http://www.64kib.com/autobuild/20190719/ 20190719: Bug fix release to allow using drives other than 1! Threw in a feature: vertical blank only turbo, press fire on cpu speed menu. This allows some display timing sensitive software to run faster, though of course is much slower...
by foft
Fri Jul 19, 2019 7:36 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

I give up. I renamed "576kcompy_PAL_VGA" to "settings". And copy it into a ROM folder "atari800/rom". Nothing changes. It still does not work. I think I will wait for it mistification version. If the hotkeys don't work try one of these ones, all those ones were composi...
by foft
Fri Jul 19, 2019 7:14 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

I fixed the drive thing, in the firmware I had a 0 where there should be the drive number - ooops! I'll rebuild fairly soon.
by foft
Fri Jul 19, 2019 9:58 am
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

No updates for a bit, broke my usb blaster cable and need to order one. + summer hols. Regarding issues: Drives: I did rewrite the menu so it’s possible. I’ll test and see what is wrong. Ntsc/cs on 5200: I suggest using the non-cs one, I just added cs for myself. I need composite sync for rgb 15khz ...
by foft
Tue Jul 16, 2019 5:27 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

exolon wrote:Unfortunately it does not work on my Dell 1908FPb. The previous versions worked very well.

Which video mode?
by foft
Sat Jul 13, 2019 8:44 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

I put up a new build here: http://www.64kib.com/autobuild/20190713/ changes: 20190713: 800xl: mist/mcc216/mcctv Profile support using sd card. Profiles had been implemented only for eclairexl/chameleon using in-built flash memory. Put sdflash.bin provided here in the rom folder. This can be used ins...
by foft
Sat Jul 06, 2019 4:51 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

I can confirm profiles are not implemented on the mist. The video/memory/system settings can be saved though, but just one set.

Interesting about the cartridges, perhaps I need to reset some of the cartridge logic when a new cartridge is inserted.
by foft
Sat Jul 06, 2019 6:37 am
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

rittwage wrote:Is there not an 800 15KHz version anymore (RGB)? I saw that variation in the 5200 version, but the 800 versions only say VGA.

It can be selected in the menu with the hotkeys.

I should have removed the _VGA.
by foft
Fri Jul 05, 2019 8:57 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

Do you have any idea how to handle system profiles?

On systems with flash I read/store the os roms + settings to flash (4 copies). I just added a big file on mcctv to simulate the same thing. I was thinking of doing that with the mist but am not sure how that fits in with the mistification.
by foft
Fri Jul 05, 2019 8:54 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

Great thanks, will try that over the weekend or early next week.

Many thanks for the osd + menu + ypbpr patch, really appreciated.
by foft
Fri Jul 05, 2019 4:33 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

I also have (Atari specific) svideo/composite output, though they are written for an 8 bit dac, not sure how good it’ll be with fewer bits.
See svideo_gtia in the EclaireXL folder.
by foft
Fri Jul 05, 2019 4:31 pm
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

You need to ‘apply settings’ for video. I’ve already got the pll reconfig working on mcctv, I was planning to share the component. If you already have a good one could you point me to it please? Then I’ll use the better one. I can cut down firmware to allow mistification. Just let me know what you n...
by foft
Fri Jul 05, 2019 6:55 am
Forum: MiST
Topic: [Atari 800 core] Mark Watson's new site
Replies: 74
Views: 7828

Re: [Atari 800 core] Mark Watson's new site

Please send me any feedback, positive as well as ‘this is broken’ :D I’m adding ‘proper’ pal/ntsc switching now. It’s more important on platforms with composite and/or svideo output than mist though. Still it means I can only have a single core for mist. Then I’ll fix the multiple profile support fo...
by foft
Thu Feb 21, 2019 3:55 pm
Forum: MiST
Topic: Atari 5200 Mistified new version
Replies: 16
Views: 2140

Re: Atari 5200 Mistified new version

Most of the good stuff has been ported both ways anyway.
by foft
Thu Dec 20, 2018 8:24 pm
Forum: MiSTer
Topic: Scaler
Replies: 392
Views: 61273

Re: Scaler

For 0 delay fans, I had success with the synced plls option discussed earlier in the thread. For the Atari 800 core on my own cyclone V board. The original pal core runs at 49.86Hz, so I overclocked it to exactly 50Hz. So 0.28% faster, but no lag. The fractional plls are very accurate, ok perhaps th...
by foft
Wed Mar 21, 2018 7:41 pm
Forum: MiSTer
Topic: ATARI ST Core
Replies: 18
Views: 7177

Re: ATARI ST Core

Yes, cycle exact 68k and ST core custom chips. That would be incredible. I hope this makes it to the top of your project list.
by foft
Tue Jul 04, 2017 6:23 pm
Forum: MiSTer
Topic: MiSTer: MiST on Terasic DE10-nano board.
Replies: 760
Views: 166226

Re: MiSTer: MiST on Terasic DE10-nano board.

Re the 800XL core. I did some work before with a similar platform - the SOCkit board. In that case I used purely block ram for the 800XL itself and I replaced the internal ZPU firmware by a linux version running on the ARM side. It communicated with the core using an avalon slave interface. I never ...
by foft
Wed May 10, 2017 7:42 pm
Forum: MiST
Topic: Atari 800 RomVault Dat for MiST released
Replies: 14
Views: 5299

Re: Atari 800 RomVault Dat for MiST released

Cool. Many thanks. Will give this a try. :D

Did you keep a list of things that didn't work, that could be interesting...
by foft
Thu Jan 12, 2017 9:34 pm
Forum: MiST
Topic: New feature: YPbPr/RGsB output
Replies: 127
Views: 38815

Re: New feature: YPbPr/RGsB output

Great idea! How flexible have you found your TV to be with component? I mean in terms of exact standard timing CEA modes? With my TVs HDMI port I find the timing needs to be really exact to the standard. Which is ok, but requires minor over/underlocking of the core to 50Hz/60Hz exactly. Other option...
by foft
Sat Dec 31, 2016 10:34 am
Forum: FPGA Chat
Topic: Introducing the VeriSNES (FPGA-based SNES)
Replies: 43
Views: 37976

Re: Introducing the VeriSNES (FPGA-based SNES)

Wow, exciting. I hope he makes it public so it can be ported. I'm particularly interested in his 65816 work for use in the Atari XL core. There are now a couple of others but from what he says this looks more complete.
by foft
Thu Jul 21, 2016 3:37 pm
Forum: MiST
Topic: MiST, NES core: switch between NTSC and PAL
Replies: 15
Views: 4914

Re: MiST, NES core: switch between NTSC and PAL

From a core vhdl perspective is there a common component being used to reconfigure the pll? The Altera pll reconfig mega functions look tricky to use.
by foft
Sat Jul 11, 2015 7:55 pm
Forum: MiST
Topic: Atari 5200 Core
Replies: 31
Views: 14346

Re: Atari 5200 Core

If one of the pins from the 5200daptor to the joystick wasn't quite in that could be it. When moving the USB to the PC perhaps it connected then moving to the mist it disconnected! I had a problem once where every time I turned round my computer switched off. It switched back on when I turned to fac...
by foft
Wed Jul 08, 2015 6:46 am
Forum: MiST
Topic: Atari 5200 Core
Replies: 31
Views: 14346

Re: Atari 5200 Core

Well the sticks and keypads are notoriously unreliable, it might need a clean!

The firmware sends the keypad buttons as key presses. It's mapped to key presses before it reaches the core.
by foft
Mon Apr 20, 2015 5:39 am
Forum: MiST
Topic: Atari 8bit core
Replies: 16
Views: 9365

Re: Atari 8bit core

Yes, but the built in joystick ports do not. So you need to connect them via USB using a 2600dapter. Also there is a key to go into 'paddle mode' (since the 2600dapter sends fire as fire not as joystick presses.)

http://home.comcast.net/~tjhafner/2600-daptor.htm

http://youtu.be/nyR-TPYOdvU
by foft
Sat Apr 18, 2015 8:02 pm
Forum: FPGA Chat
Topic: Cheap VGA->HDMI adapter
Replies: 52
Views: 31753

Re: Cheap VGA->HDMI adapter

This one has a jack input, bit more pricey though.

http://www.keene.co.uk/coosis-portable- ... ertor.html

Go to advanced search