Search found 241 matches

by Shockwav3
Sat May 11, 2019 3:04 pm
Forum: Hardware
Topic: [ATW800] Blossom/X11r4 palette issues
Replies: 7
Views: 1916

Re: [ATW800] Blossom/X11r4 palette issues

Digging this out once again ... turns out the RAMDAC was broken.
Replacing it helped. No idea why the "harness" managed to produce an output that seemed fine tho - not that I care anymore at this point :)
https://i.imgur.com/tHkltVG.jpg
by Shockwav3
Sun Apr 21, 2019 11:31 am
Forum: Professionals
Topic: Setting up an ATW800 + Farmcard
Replies: 7
Views: 2312

Re: Setting up an ATW800 + Farmcard

Just stick around ... the project is still in the early concept phase.
by Shockwav3
Sun Apr 21, 2019 10:38 am
Forum: Professionals
Topic: Setting up an ATW800 + Farmcard
Replies: 7
Views: 2312

Re: Setting up an ATW800 + Farmcard

Why? That way you might get a 25 CPU, 4+48MB ATW instead of 13 CPU, 4+12MB max.
That's a considerable increase in power in my book.
by Shockwav3
Sat Apr 20, 2019 1:45 pm
Forum: Professionals
Topic: Setting up an ATW800 + Farmcard
Replies: 7
Views: 2312

Re: Setting up an ATW800 + Farmcard

There might possibly be a project in the pipeline for a compatible, but more powerful solution (up to 8 CPUs with 2MB each per card [original: 4CPUs with 1MB each]) by someone (not me).
by Shockwav3
Sat Apr 20, 2019 10:49 am
Forum: Professionals
Topic: Setting up an ATW800 + Farmcard
Replies: 7
Views: 2312

Setting up an ATW800 + Farmcard

Hey there, since the farmcard I was sold has arrived here on thursday I spent yesterday setting it up. As far as I can judge the card is fully functional and booting it up works without hassle. Without X (console only) I'm encountering no issues - yet as soon as X gets involved the farmcard becomes ...
by Shockwav3
Wed Apr 10, 2019 12:00 pm
Forum: Hardware
Topic: [ATW800] Blossom/X11r4 palette issues
Replies: 7
Views: 1916

Re: [ATW800] Blossom/X11r4 palette issues

Looks like it's a bug in X11, luckily the port comes with it's own hotfix: https://youtu.be/WIwuuDOhUGQ
by Shockwav3
Tue Apr 09, 2019 8:22 am
Forum: Hardware
Topic: [ATW800] Blossom/X11r4 palette issues
Replies: 7
Views: 1916

Re: [ATW800] Blossom/X11r4 palette issues

https://i.imgur.com/CayjGfe.jpg Looks serverely broken, but this pretty much confirms to me that the hardware is able to adress it's CLUT completely. This was done using the "harness" tool from Helios 1.31 which sets colorbars in a few shades of the primary colors over the whole screen and...
by Shockwav3
Mon Apr 08, 2019 11:49 am
Forum: Hardware
Topic: [ATW800] Blossom/X11r4 palette issues
Replies: 7
Views: 1916

Re: [ATW800] Blossom/X11r4 palette issues

I'm just the guy servicing it :) I have to admit I find the machine to be quite underwhelming currently and using X it runs out of memory quite fast ... but then again, X with 4MB is quite an achievement already (additionally, the machine has no farmcard as of now ... but I managed to have one shipp...
by Shockwav3
Mon Apr 08, 2019 10:34 am
Forum: Hardware
Topic: [ATW800] Blossom/X11r4 palette issues
Replies: 7
Views: 1916

[ATW800] Blossom/X11r4 palette issues

Since I've succeded in installing X11 on Helios 1.3 I guess it's time for another thread, focusing on another issue. So far the machine is behaving nicely, it runs stable and the Helios/X11 enviroment usually does what I tell it to do. Checking the palette using the "showcols" tool I've en...
by Shockwav3
Sat Apr 06, 2019 6:19 am
Forum: Professionals
Topic: Questions about ATW800 hdd install
Replies: 34
Views: 10132

Re: Questions about ATW800 hdd install

RGsB to VGA adapter is working (Mode2 and Mode0): https://i.imgur.com/8II14H1.jpg EDIT: Seems like either part of the RAM is dead or the muxing/latching has issues.That's bad :( EDIT2: Attempting to downgrade the framebuffer driver in the hopes that this fixes things. If it's a hardware fault, it's ...
by Shockwav3
Wed Apr 03, 2019 10:57 pm
Forum: Professionals
Topic: Questions about ATW800 hdd install
Replies: 34
Views: 10132

Re: Questions about ATW800 hdd install

https://i.imgur.com/SQxgPxn.jpg

X is working, running under Helios 1.3 in mode2 (640x480x8bpp). Sadly the monitor I have at hand currently isn't syncing correctly
by Shockwav3
Sun Mar 31, 2019 8:12 pm
Forum: Professionals
Topic: Questions about ATW800 hdd install
Replies: 34
Views: 10132

Re: Questions about ATW800 hdd install

Slowly getting there: https://i.imgur.com/VPHOXYi.jpg Now if only the window manager wasn't failing, that would be great. EDIT: TWM is working, spawning anything still fails tho (gotta have to read into xauth) - but I guess I'm making a good bit of progress. "Exec format error" is fixed by...
by Shockwav3
Sat Mar 30, 2019 9:37 pm
Forum: Professionals
Topic: Questions about ATW800 hdd install
Replies: 34
Views: 10132

Re: Questions about ATW800 hdd install

Well ... I've got things installed and it's no longer complaining about missing files, but this doesn't look too promising ... "Exec format error" and "fatal server bug" without any further info seems like a dead end to me: https://i.imgur.com/PSpha7U.jpg Stupid me ... reading &q...
by Shockwav3
Sat Mar 30, 2019 3:27 pm
Forum: Professionals
Topic: Questions about ATW800 hdd install
Replies: 34
Views: 10132

Re: Questions about ATW800 hdd install

Can anyone of you verify/deny that the ATW800 can handle 16MB of RAM? Just tried a few sticks after reading that info online ... sadly those are still getting detected as 4MB.
by Shockwav3
Fri Mar 29, 2019 6:16 pm
Forum: Professionals
Topic: Questions about ATW800 hdd install
Replies: 34
Views: 10132

Re: Questions about ATW800 hdd install

Well, I got as far as setting up HFS/rawdisk at least. Since I used the NEC D3841 supplied with this machine (which should be the original drive), installation might be different for you. These are the steps I've taken so far: - Format the first 71 cylinders as GEM using MSCSIFMT.PRG - Copy/Install ...
by Shockwav3
Fri Mar 29, 2019 2:21 pm
Forum: Professionals
Topic: Questions about ATW800 hdd install
Replies: 34
Views: 10132

Re: Questions about ATW800 hdd install

Well, currently I'm digging into the HFS, since that might be a possible solution, as HFS supports partition sizes of considerable size (at least various 100s of MB). So far I have a 7MB GEM-swap partition and a ~35MB "raw"/Helios-Partition. The raw one gets mapped to /rawdisk with a size ...
by Shockwav3
Thu Mar 28, 2019 11:03 pm
Forum: Professionals
Topic: Questions about ATW800 hdd install
Replies: 34
Views: 10132

Re: Questions about ATW800 hdd install

Any news on that? I'm currently facing exactly the same issue. Drive is a NEC D3841 with ~45MB which originally came with the ATW800. It's working as it should, but I can't get partitions beyond ~16MB - whereas X11 requires 30MB of continous disk space. The HeliOSFS seems to be such a can of worms I...
by Shockwav3
Sat Jul 01, 2017 9:18 pm
Forum: For sale / Wanted
Topic: Pak68/3 32MHz on eBay
Replies: 12
Views: 4262

Re: Pak68/3 32MHz on eBay

atari.wroc.pl has reproductions of the FRAK/2
by Shockwav3
Wed Jun 21, 2017 10:31 am
Forum: Hardware
Topic: Contemporary towerized 520ST
Replies: 12
Views: 2938

Re: Contemporary towerized 520ST

I've added an internal floppy connector ... it's a bit of a hackjob (since I didn't want to spend 9€ on a DIN14M connector or hack up the Golem floppy), but I think it's a decent deal between functionality and serviceability.
http://i.imgur.com/hFMh8Lp.jpg
http://i.imgur.com/NoXAueg.jpg
by Shockwav3
Sat Jun 17, 2017 1:00 pm
Forum: Hardware
Topic: Contemporary towerized 520ST
Replies: 12
Views: 2938

Re: Contemporary towerized 520ST

Just gave the machine a spin with YAART (8 passes) and TESTRAM.TOS - RAM seems to be fine :)
Floppy also works nicely (it's a 'Golem' drive by Kupke with a nice track display)
Last but not least I got a second external keyboard so I don't need to constantly swap one between 3 machines.
by Shockwav3
Thu Jun 15, 2017 6:09 pm
Forum: Hardware
Topic: Contemporary towerized 520ST
Replies: 12
Views: 2938

Re: Contemporary towerized 520ST

The tower originally came with a Hypercache and a PAK68/3 but was taken out by the guy who gifted it to me, as he has some use for it himself. I'll likely put in a PAK68/3 myself at one point. Future things to do: - clean up the mods (they're not exactly well soldered) - add ribbon cables and backpl...
by Shockwav3
Thu Jun 15, 2017 3:48 pm
Forum: Hardware
Topic: Contemporary towerized 520ST
Replies: 12
Views: 2938

Re: Contemporary towerized 520ST

Turns out you were right greenious. The video mod is an overscan mod that needs LACESCAN.PRG to run.
http://i.imgur.com/NyyihLs.jpg
by Shockwav3
Wed Jun 14, 2017 9:02 pm
Forum: Hardware
Topic: Contemporary towerized 520ST
Replies: 12
Views: 2938

Re: Contemporary towerized 520ST

Some updates: - RTC circuit has been found (it's a DIY on breadboard) - Sockets/Jacks have been added to the board again - yellow tint is gone - Installed an RJ45 (still not ideal) socket for the keyboard - works - HDDs work - cleaned up the tower https://imgur.com/a/bl317 Next steps will be adding ...
by Shockwav3
Tue Jun 13, 2017 7:05 pm
Forum: For sale / Wanted
Topic: PAK68/3, FRAK/2 & PuPla
Replies: 4
Views: 2385

Re: PAK68/3, FRAK/2 & PuPla

Prices are a total ripoff tho.
Makes me wonder if I should continue my rePAK project and release them publically at some point ... even tho that may attract scalpers even more.
The boards offered were made by artur of http://atari.wroclaw.pl/ (who is not the eBay seller)

Also thread necromancy :)
by Shockwav3
Tue Jun 13, 2017 3:28 pm
Forum: Hardware
Topic: Contemporary towerized 520ST
Replies: 12
Views: 2938

Re: Contemporary towerized 520ST

I managed to pull out the differences between my ROMDump (left column) and TOS104GE.IMG I found on the internet and used in Steem for quite a bit (CRC-32 for the latter is 6A5CED85). Overall 104 bytes are different, maybe someone can roughly interpret the changes? 448: 6A 64 4B8: 30 10 C7C: DE 5C C7...

Go to advanced search