Search found 39 matches

by alexb
Sat Jun 23, 2018 5:19 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

tenox wrote:Another unsolved mystery so far is relinking the kernel. I was not able to do it to date.

My notes mention to "touch /stand/system to rebuild unix on the next reboot", but I don't remember if that worked on both images or not.
by alexb
Sat Jun 23, 2018 4:49 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

... The sad thing is that Firefox itself is a little heavy, but just browsing simple pages isn't too bad, it's the ones that are heavily written in java script and flash that just make everything chug... I wasn't talking about running Firefox on the TT, but redirect its display to it using the X-Wi...
by alexb
Sat Apr 30, 2016 9:18 am
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

I have asv on a hard drive..it no longer boots at all. Are there any utilities on floppy or other that I can run to try and "fix" the hard drive...it is recognized as a scsi device when I boot from ICD but i'm not sure what to try. I may have a tape backup but I need to check the disk out...
by alexb
Sat May 02, 2015 9:46 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

I actually did it the hard way resizing existing partitions from single user mode. Did you manage to make a new disk bootable? I've played with partinit to install rootsector and bootsector, but when I try to boot from the device, the kernel is being loaded, and in the end booting aborts with the d...
by alexb
Sat May 02, 2015 1:00 pm
Forum: Hardware
Topic: ST Book problems
Replies: 5
Views: 1603

Re: ST Book problems

Dal wrote:There's also a motherboard reset procedure you can try:
Remove batteries and PSU, hold sleep and power for half a minute or so then power up again.

Oh, thanks, didn't know about that. I'll try that one first.
by alexb
Sat May 02, 2015 12:57 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

Oh hey, asv-mark contains an /UPDATE-1.1-06 directory with update files and install scripts... I'll try to apply that to the richard image, which seems like a much more clean install overall.
by alexb
Fri May 01, 2015 7:23 pm
Forum: Hardware
Topic: ST Book problems
Replies: 5
Views: 1603

ST Book problems

The harddisk in my ST Book has died (doesn't spin up anymore). When I turn on the system with no HDD connected, I just get four bombs after the memory test. I seem to remember that there should be a ROM disk with the harddisk utilities that should be accessible even when the IDE disk has failed - bu...
by alexb
Fri May 01, 2015 6:49 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

The problem is that TT SCSI bus is not much faster than this, only about 1.8 MB/s. There is another topic on the forum discussing this. Yeah, I've seen that... But that's barely 300 k /sec up there. Btw, there's an updated firmware - it seems if you run a version between 4.1.1 and 4.2.2, anything b...
by alexb
Fri May 01, 2015 6:42 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

Trying to prepare a new disk with /sbin/partinit - seems the tool really has a problem with large disks. I couldn't create an ASV disklabel on a 2.5G SCSI2SD disk (error writing sector 0). No such problem on a 1G disk. The "new disk" tool /usr/local/sbin/X11/newd actually creates a shell s...
by alexb
Sun Apr 19, 2015 9:28 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

Btw., with recent SCSI2SD firmware you can define up to four SCSI IDs on different areas of the same card. Seriously? That's awesome! Does it also support larger cards like SDHC? That would help a lot with constructing a larger file system. Biggest card I have in a SCSI2SD is 16GB. Sliced into four...
by alexb
Fri Apr 17, 2015 2:03 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

I actually did it the hard way resizing existing partitions from single user mode. Now I've got a second SCSI2SD so I plan hook it up on another SCSI ID as a second disk and do it properly without affecting a live system. Btw., with recent SCSI2SD firmware you can define up to four SCSI IDs on diff...
by alexb
Thu Apr 16, 2015 7:08 am
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

Slow progress (now running off a SCSI2SD)... https://lh3.googleusercontent.com/-XO6n_A70qy4/VS9cH9ji4QI/AAAAAAAAEoA/pfNgll_f8Yk/w900-h589-no/P1050957.jpg I remember someone telling me that he managed to build a newer X11 release for ASV back in the days... Not shure I'll bring up the patience to wai...
by alexb
Fri Feb 20, 2015 9:35 pm
Forum: Website Discussions
Topic: site blocked for certain browsers?
Replies: 2
Views: 5128

Re: site blocked for certain browsers?

Great, thanks. Real Firefox on Android isn't hit by this either, so I guess the number of other possibly affected users will be near zero :)
by alexb
Fri Feb 20, 2015 8:58 pm
Forum: Website Discussions
Topic: site blocked for certain browsers?
Replies: 2
Views: 5128

site blocked for certain browsers?

Whenever I try to access http://www.atari-forum.com with Pale Moon (a Firefox variant) on my Android tablet, I get a 403 "You don't have permission to access / on this server" message. Pale Moon's user agent string is "Mozilla/5.0 (Android; Tablet; rv:25.2) Gecko/25.2 Firefox/31.9 Pal...
by alexb
Thu Feb 19, 2015 11:24 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

I actually did it the hard way resizing existing partitions from single user mode. Now I've got a second SCSI2SD so I plan hook it up on another SCSI ID as a second disk and do it properly without affecting a live system. I will publish the steps and the final image once I complete the process. Ah,...
by alexb
Wed Feb 18, 2015 10:12 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

tenox wrote:Richard's image suffered from a similar problem and I had to spend a considerable amount of time extending and re-arranging the file systems.

How did you do that? I never had the patience to learn deal with the filesystem utilities myself...
by alexb
Thu Jan 16, 2014 9:12 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

I wish someone knew what the modifications were. Mark's image booted fine, but would crash after a short time on my TT. However it looked great on the high resolution monitor! Ah! English versions of the TT technical bulletins are online after all, here: http://www.ataritt030.info/index_uk.php?menu...
by alexb
Wed Jan 15, 2014 9:27 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

Finally found some time to boot the fixed mark image on my TT. Haven't seen any problems so far, but it's not as if I did much besides poking around in the home directories (this system seems to have been in active use somewhere in the netherlands). Even has a perl4 in /usr/local/bin... As for SCSI ...
by alexb
Sun Nov 24, 2013 10:13 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

To my knowledge, ASV never had proper ACSI support (although it _might_ be possible to have the root sector on an ACSI disk since the boot code uses DMAread() to get at it). Sorry - I thought I had seen that in the release notes somewhere, but upon checking the documentation, it actually sais: Note...
by alexb
Sun Nov 24, 2013 11:45 am
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

Also tried with Artmix CF AztecMonster. But that never works. Are there any other SCSI to IDE bridges / adapters? For SD cards on an Atari, there's the Gigafile , which works very well as ACSI device (SCSI mode seems somewhat experimental from what I heard). At least according to the ASV documentat...
by alexb
Sun Nov 24, 2013 11:33 am
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

The easiest way is to attach 50pin scsi controller to your pc and boot some live linux dist. Then just write the image using dd. Sadly, no SCSI on the PC side anywhere. I was using NetBSD/atari to dd the file to another disk (sending the image over network via netcat - so that needs a network card ...
by alexb
Tue Nov 12, 2013 6:38 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

C is all closed on mine. B is close/open/close. I have my card configured for AUI (A to top), and use an AUI/TP transciever. Contrary to the NetBSD FAQ, that one needs D in the top position, because otherwise the transciever isn't powered. I didn't fully walk through the network configuration, but i...
by alexb
Sun Nov 10, 2013 3:06 pm
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

By the way, asv_mark actually seems to be the more recent version. (No, didn't boot it yet, just had another look at some of the strings in the image files...) asv_richard: @(#) /usr/local/bin/gcc, version 1.39-05 Gnu C compiler Tue Aug 27 17:52:43 EDT 1991 asv_mark: @(#) /usr/local/bin/gcc, version...
by alexb
Sun Nov 10, 2013 11:33 am
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

Turns out gcc 1.40 in ASV is good enough to compile gzip 1.2.4 :) # ./gzip -V gzip 1.2.4 (18 Aug 93) Compilation options: DIRENT UTIME STDC_HEADERS HAVE_UNISTD_H [edit] ...and gcc 2.7.2.3 still contains a configuration for m68k-atari-sysv4: # ./configure --prefix=/usr/local --program-suffix=-2.7.2.3...
by alexb
Sun Nov 10, 2013 10:58 am
Forum: Professionals
Topic: Atari TT030 and system V
Replies: 353
Views: 106261

Re: Atari TT030 and system V

I use the riebl settings from the NetBSD/atari FAQ: http://www.netbsd.org/ports/atari/faq.html#riebl Can't get routing to work atm (there is a default route in the table, but I still can't reach any system outside the local network)... Now to bootstrap a more recent gcc ;) (I think maybe something i...

Go to advanced search