Search found 494 matches

by rpineau
Tue Aug 01, 2017 1:25 am
Forum: Professionals
Topic: ED (2.88mb) Floppy Upgrade for Falcon
Replies: 40
Views: 1599

Re: ED (2.88mb) Floppy Upgrade for Falcon

The 32 MHz goes to the DSP pin 74 (named EXTAL) and DMA pin 10 (named DSP_32_I with a signal named DSP_32M going to it). When you overclock the DSP, you cut the 32MHz line between the oscillator and the DSP, then wire a new oscillator (50MHz) directly to the DSP, leaving the 32MHz to DMA untouched s...
by rpineau
Sat Jun 24, 2017 8:07 am
Forum: News & Announcements
Topic: Ataribox
Replies: 12
Views: 2235

Re: Ataribox

Use google.. it's good.. you'll see ...
https://www.polygon.com/e3/2017/6/16/15 ... ew-console
by rpineau
Fri Jun 23, 2017 9:42 pm
Forum: News & Announcements
Topic: Ataribox
Replies: 12
Views: 2235

Re: Ataribox

PC based hardware ... . . . . .
by rpineau
Wed Jun 07, 2017 3:41 pm
Forum: Hardware
Topic: 68020 booster
Replies: 137
Views: 36253

Re: 68020 booster

We're in the process of ordering the new revision of the pcb for our V3 proto which if everything goes well will become the final version (we will remove the test headers for the final version but that's about it). We don't intend to sale it but to make all files available as an open source project ...
by rpineau
Wed May 31, 2017 3:37 am
Forum: News & Announcements
Topic: SLCC - San Lenadro Computer Club Meeting SF-Bay Area
Replies: 3
Views: 911

Re: SLCC - San Lenadro Computer Club Meeting SF-Bay Area

Argg.. I won't be able to make this time. I didn't even know about you guys.
I'll try to plan for the July meeting (it's just 30mn from my place).
I might bring a few proto of the 68020 card to show around (I might even have time to fix them and bring the MSTE with a card in it).
Regards, Rodolphe
by rpineau
Fri May 26, 2017 6:19 am
Forum: Hardware
Topic: TT and MSTe PSU
Replies: 15
Views: 1718

Re: TT and MSTe PSU

The -5V is used by the DAC0802 in the Mega STE and TT. It might be used in other places.
by rpineau
Tue May 23, 2017 12:59 am
Forum: Hardware
Topic: STE BOOSTER V1 32MHZ & FAST-TOS
Replies: 199
Views: 23836

Re: STE BOOSTER V1 32MHZ & FAST-TOS

Agreed .. the FPGA still used an external ram in which it "copies" the full 4MB STRAM while snooping so that it can then render from it (aka similar to what supervidel is doing, except it only snoop whatever it needs from the screen video start address + size of a frame). There are many wa...
by rpineau
Mon May 22, 2017 9:25 pm
Forum: Hardware
Topic: STE BOOSTER V1 32MHZ & FAST-TOS
Replies: 199
Views: 23836

Re: STE BOOSTER V1 32MHZ & FAST-TOS

Both the VA2000 (Amiga) and the VBXE (8 bit Atari) have their own RAM onboard.
by rpineau
Mon May 22, 2017 9:21 pm
Forum: Hardware
Topic: STE BOOSTER V1 32MHZ & FAST-TOS
Replies: 199
Views: 23836

Re: STE BOOSTER V1 32MHZ & FAST-TOS

Any "video card" we build will not access the ST RAM. It will have its own RAM. Having the GPU (Epson, FGPA, ...) drive its own ram is the best way to get fast video with a higher resolution. Making something that access the ST RAM would require it to interface between the GLUE/MMU and RAM...
by rpineau
Mon May 22, 2017 5:06 pm
Forum: Hardware
Topic: STE BOOSTER V1 32MHZ & FAST-TOS
Replies: 199
Views: 23836

Re: STE BOOSTER V1 32MHZ & FAST-TOS

Yes the chip has a dedicated SDRAM (or EDO DRAM) for the video frame buffer and other feature (sprites ...) and depending on the chip this RAM is more or less big :) The epson chip are cheap (around $20 to $30 max), but they do not have any video mode compatible with Falcon or ST 4/8 interleaved pla...
by rpineau
Mon May 22, 2017 4:44 pm
Forum: Hardware
Topic: STE BOOSTER V1 32MHZ & FAST-TOS
Replies: 199
Views: 23836

Re: STE BOOSTER V1 32MHZ & FAST-TOS

Yes, the chip requires external RAM for the video and other function (1 chip of 16 bit SDRAM, 8 or 16 MB for the QFP package, 8/16/32 or 64MB for the PBGA package). The IC should be fully accessible at 32MHz and if you copy data from ram to its SDRAM (not accessible as is, only via the chip) it woul...
by rpineau
Mon May 22, 2017 4:13 pm
Forum: News & Announcements
Topic: GEMBENCH 6
Replies: 112
Views: 20824

Re: GEMBENCH 6

The 68030 cache is controlled by software, So you can totally de-activate it on the TT (and any 68030 machine).
Rodolphe
by rpineau
Mon May 22, 2017 4:10 pm
Forum: Hardware
Topic: STE BOOSTER V1 32MHZ & FAST-TOS
Replies: 199
Views: 23836

Re: STE BOOSTER V1 32MHZ & FAST-TOS

For the FPGA, I do know some VHDL as we're doing the code for the CPLD we use on the 68020 card using VHDL. I read his code (and talked to him and his totally fine with us using his code for an open source video card for Atari computers) and it's fairly simple. We'll probably still need a small CPLD...
by rpineau
Mon May 22, 2017 12:02 am
Forum: Hardware
Topic: STE BOOSTER V1 32MHZ & FAST-TOS
Replies: 199
Views: 23836

Re: STE BOOSTER V1 32MHZ & FAST-TOS

The Epson chip is not bad, but it's not the fastest thing on the planet :) I have an Eagle design for 68020 bus with it (as the plan is to make one for our cards) but the S1D13506 also has a 68000 bus mode so it could be adapted easily from my schematics. Also the "don't use in new projects&quo...
by rpineau
Thu May 11, 2017 12:09 am
Forum: Hardware
Topic: Atari TT boots to desktop but black screen with diagnostic cartridge plugged in
Replies: 7
Views: 922

Re: Atari TT boots to desktop but black screen with diagnostic cartridge plugged in

Your TT might have the cartridge port fuse burned. If this is the case when you plug the cartridge it pulls all lines to LOW and would probably give you the black screen you see.
Check the fuse with a multimeter.
Rodolphe
by rpineau
Tue May 09, 2017 3:09 pm
Forum: Professionals
Topic: NetUSBee troubles
Replies: 14
Views: 1307

Re: NetUSBee troubles

Ok. Next thing would be , if you have a managed switch (I use Cisco and Arista switches), to check if the port goes in errdisable on the switch and if it does what is the reason for this. At this point as it fails with multiple TCP/IP stack and other tools it's most probably a hardware issue like a ...
by rpineau
Tue May 09, 2017 2:41 pm
Forum: Professionals
Topic: NetUSBee troubles
Replies: 14
Views: 1307

Re: NetUSBee troubles

IT seems that the MAC address is not set on the chip. The NetUSBee when it comes from Lotharek is supposed to already have a MAC set. If your MAC is not set the switch/router will not know to which MAC to send packets and that's probably why it doesn't work even though everything is up. In MiNT, if ...
by rpineau
Wed May 03, 2017 3:37 pm
Forum: News & Announcements
Topic: EmuTOS 0.9.8
Replies: 46
Views: 4735

Re: EmuTOS 0.9.8

True, but here we're just displaying the value, this was to demonstrate the size of each type, but if you do indeed need to use sizeof() in an expression (other than printing) you also run into issues (gcc complained about that on OS X when I compiled the above but I didn't care for this case). Here...
by rpineau
Wed May 03, 2017 3:06 pm
Forum: News & Announcements
Topic: EmuTOS 0.9.8
Replies: 46
Views: 4735

Re: EmuTOS 0.9.8

One more test to show the issues : on Atari : Screen Shot 2017-05-03 at 8.03.45 AM.png On a 64 bit Intel CPU (OS X) : size of char : 1 size of short : 2 size of int : 4 size of long : 8 size of pointer : 8 same code on both machines : #include <stdio.h> #include <stdlib.h> #include <string.h> #inclu...
by rpineau
Wed May 03, 2017 3:01 pm
Forum: News & Announcements
Topic: EmuTOS 0.9.8
Replies: 46
Views: 4735

Re: EmuTOS 0.9.8

yep. I even tested the above on a 64 bit machine... still says 2
The issue is really with int, long and pointers (and using one for the other).
by rpineau
Wed May 03, 2017 2:46 pm
Forum: News & Announcements
Topic: EmuTOS 0.9.8
Replies: 46
Views: 4735

Re: EmuTOS 0.9.8

On Atari, this : #include <stdio.h> #include <stdlib.h> #include <string.h> #include <fcntl.h> #include <osbind.h> #include <mint/sysvars.h> typedef struct { char a; char b; } TEST; int main(int argc, char* argv[]) { printf("size of TEST : %d\n", sizeof(TEST)); Cconin(); return 0; } will d...
by rpineau
Fri Apr 28, 2017 3:35 pm
Forum: For sale / Wanted
Topic: Devpac manual
Replies: 2
Views: 497

Re: Devpac manual

by rpineau
Mon Apr 24, 2017 3:09 pm
Forum: Hardware
Topic: 68020 booster
Replies: 137
Views: 36253

Re: 68020 booster

Quick update: We're still working on this ... but I had some issues. The PCB quality is not what I was expecting . My first MSTE board that was working is no longer working. So far by doing a continuity test I have found at least 4 signals that are no longer connected (I might be able to fix these)....
by rpineau
Thu Apr 20, 2017 4:08 pm
Forum: Hardware
Topic: TT and MSTe PSU
Replies: 15
Views: 1718

Re: TT and MSTe PSU

I use a 120W Pico PSU on the TT and no problem so far.
The original TT/MSTE PSU are 64.6W so you should be good even if you add a lot of things to it.

Rodolphe
by rpineau
Sun Mar 26, 2017 5:49 pm
Forum: Hardware
Topic: Afterburner040 030 switch
Replies: 9
Views: 1302

Re: Afterburner040 030 switch

On my machine ... te 68030 was totally remove :) .. no going back .. so no switch :)

Go to advanced search