Search found 245 matches

by Ektus
Sat Mar 30, 2019 4:53 pm
Forum: Games
Topic: Hex-a-hop
Replies: 28
Views: 2750

Re: Hex-a-hop

Thanks Ektus for tests. It would be playable if there weren't massive problems with the Eiffel (mouse too fast? Have to check with older one...) Thats strange for me. In my case I could never make mouse working for this game. Either I get no mouse pointer and other times ( happening really rarely )...
by Ektus
Sat Mar 30, 2019 6:02 am
Forum: Games
Topic: Hex-a-hop
Replies: 28
Views: 2750

Re: Hex-a-hop

On the CT63 with Radeon and MAgiC, there are two messages in the console: C:\gemini2\user> Warning: unable to open file "./data/" for reading Warning: don't know window width for message: It would be playable if there weren't massive problems with the Eiffel (mouse too fast? Have to check ...
by Ektus
Sat Mar 30, 2019 5:52 am
Forum: Games
Topic: Hex-a-hop
Replies: 28
Views: 2750

Re: Hex-a-hop

The error I get on the CT63 is an alert from XaAES with "pid 161 (hexahop): BUS ERROR: User PC=3C, Address: 3C (basepage 2314000, text=2314100, data=24B22A4, bss=24BD1A4)" It's an old version of MiNT 0.17 from 2012 with XaAES to match (0.999 release Nov 3 2012) This hasn't changed with th...
by Ektus
Fri Mar 29, 2019 8:55 pm
Forum: Games
Topic: Hex-a-hop
Replies: 28
Views: 2750

Re: Hex-a-hop

Tried the new version on my CT2A Falcon (14+32MB, MagiC 6.2): Seems to behave like before, switches resolution, shows menu screen, mouse cursor freezes, no response whatsoever. Need reset button to recover. More tests to come tomorrow.
by Ektus
Sun Mar 24, 2019 6:19 pm
Forum: Games
Topic: Hex-a-hop
Replies: 28
Views: 2750

Re: Hex-a-hop

Tried on my Milan 040 with MagiC-Milan and ATI Rage in 1600x1200x65k: Crashes badly, Exception #2 h:\HEXAHOP> HEXAHOP.PRG Exception #2: PC=01665586 (TEXT+000914B6), USP=017C7AF6, SR=2000 Fault address:FFFF8930 Effective address:017C7AF6 Dn:01528C6C 00000000 0000000A 00000008 00000000 00000001 000020...
by Ektus
Sat Mar 23, 2019 8:43 pm
Forum: Games
Topic: Hex-a-hop
Replies: 28
Views: 2750

Re: Hex-a-hop

The error I get on the CT63 is an alert from XaAES with "pid 161 (hexahop): BUS ERROR: User PC=3C, Address: 3C (basepage 2314000, text=2314100, data=24B22A4, bss=24BD1A4)"

It's an old version of MiNT 0.17 from 2012 with XaAES to match (0.999 release Nov 3 2012)

Regards
Ektus.
by Ektus
Fri Mar 22, 2019 9:12 pm
Forum: Games
Topic: Hex-a-hop
Replies: 28
Views: 2750

Re: Hex-a-hop

I've got the download from the link in the first post, unpacked the ZIP to a SD-card with LFN (FAT32) and tried several systems. - CT2A Falcon running MagiC in 256 colours: Start image is displayed (very slowly) in full screen, then nothing. Mouse cursor frozen. -CT63@95 running MagiC on Radeon in 1...
by Ektus
Thu Mar 07, 2019 5:15 am
Forum: CT60 / CT63 Area
Topic: CT63 temperature in F030 mode
Replies: 6
Views: 2064

Re: CT63 temperature in F030 mode

I don't think it's possible to access the temperature sensors from 030 mode. CT63 normally doesn't have the necessary components anyway. The CPU temp may be estimated by touching the heat sink with your finger or a thermometer, though, and I guess that's what has been asked in the first post. Regard...
by Ektus
Sat Jan 12, 2019 12:17 pm
Forum: News & Announcements
Topic: MagiC/MagiCMacX source updated
Replies: 44
Views: 6720

Re: MagiC/MagiCMacX source updated

According to a user of the german forum, they should work already. He used magic_p.tos to patch the resulting magic.ram (source included, but not currently build; has to be verified if that still is needed) and a slightly modified version of the ct60 specific boot program (also not currently build,...
by Ektus
Wed Jan 02, 2019 3:41 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and Demos
Replies: 12
Views: 1459

Re: CTPCI and Demos

I've got monitors with multiple inputs. Switching isn't automatic, but the only thing needed is a pair of data cables. 1x VGA for the Videl, 1x DVI for the Radeon.

Regards
Ektus.
by Ektus
Tue Jan 01, 2019 9:43 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and Demos
Replies: 12
Views: 1459

Re: CTPCI and Demos

In the "Video ATI Radeon" CPX select "DRIV" in the bottom right, select your resolution in the list, and double-click the resolution. The dialog will prompt you to change the resolution and also show the mode code. For me, it's 0xC31D for 1920x1200-32@59Hz. 1920x1080-32@60Hz woul...
by Ektus
Sun Dec 30, 2018 3:35 pm
Forum: Applications
Topic: SYSREC a tool to record system calls of an application
Replies: 13
Views: 1325

Re: SYSREC a tool to record system calls of an application

Isn't manitor also suited for this task, and also for multitasking? http://www.atariuptodate.de/en/1939/manitor
by Ektus
Fri Dec 28, 2018 10:30 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 41097

Re: CTPCI and Realtek 8139D

I did it under mint, but it should also work under TOS if you have a terminal window. Easiest way would be Gemini 1.a as desktop, launch the internal Mupfel shell and start

Code: Select all

lspci.ttp -vv -i k:\PCI > kroll.txt
by Ektus
Fri Dec 28, 2018 1:24 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 41097

Re: CTPCI and Realtek 8139D

Here's the output from my Falcon: 00:00.0 Bridge: PLX Technology, Inc. PCI9054 32-bit 33MHz PCI <-> IOBus Bridge (rev 0c) Subsystem: PLX Technology, Inc. PCI9054 32-bit 33MHz PCI <-> IOBus Bridge Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx- St...
by Ektus
Fri Dec 28, 2018 1:09 pm
Forum: Hardware
Topic: Modern multisync monitors?
Replies: 26
Views: 4591

Re: Modern multisync monitors?

With my CT2A machine (25MHz Bus, 50MHz Videl) using centvidel I'm able to get 1600x928x256 at 28Hz refresh rate on the U2410. The monitor thinks it's 1600x1000@28Hz, the picture is almost perfect after manually adjusting the "Phase" value to something around 90. Setting aspect ratio to 1:1...
by Ektus
Thu Dec 27, 2018 9:24 pm
Forum: C / PASCAL etc.
Topic: MagiC & spinmxfs.xfs (iso filesystem for CDs)
Replies: 20
Views: 2035

Re: MagiC & spinmxfs.xfs (iso filesystem for CDs)

IIRC, 0.34 was the last beta and available only on request (not for general distribution). I've got it, too, but it's been a loooooong time.
by Ektus
Thu Dec 27, 2018 8:34 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 41097

Re: CTPCI and Realtek 8139D

Can you please post the exact type of USB card you are using? Perhaps i´ll give it another try... vendor id= 0x1033 device id = 0x0035 & 0x00e0 https://pci-ids.ucw.cz/read/PC/1033/00e0 Looks like a NEC Corporation uPD72010x USB 2.0 Controller Those are the same IDs that are shown with my setup....
by Ektus
Mon Dec 17, 2018 4:18 am
Forum: CT60 / CT63 Area
Topic: CTPCI and Falcon IDE
Replies: 2
Views: 1037

Re: CTPCI and Falcon IDE

Is the CT6X seated properly? I'd suspect a bad connection to the Falcon Mainboard. To rule out problems with the CTPCI, remove it and try without.
by Ektus
Sun Dec 09, 2018 7:00 am
Forum: Professionals
Topic: Atari Falcon IDE to CF
Replies: 34
Views: 3714

Re: Atari Falcon IDE to CF

I've got a Falcon with the same type of problem, in my case the ribbon cable to the original 80MB HDD was inserted shifted to the side. Result: One wire of the ribbon cable melted and IDE port on Falcon mainboard damaged beyond repair. The Falcon works just fine as long as nothing is connected there...
by Ektus
Sat Dec 08, 2018 10:39 am
Forum: Professionals
Topic: Can somebody compile a Netsurf that works with 256 colours?
Replies: 44
Views: 4416

Re: Can somebody compile a Netsurf that works with 256 colours?

Old versions from back then might work in 256 colours, but are pretty outdated as far as standards, JavaScript and the like are concerned. Pretty slow, too, so rather than as proof of concept they are of little use for actual surfing. Testing a build of netsurf 3.0 alpha from September, 2011 on my C...
by Ektus
Sun Nov 25, 2018 4:53 am
Forum: Website Discussions
Topic: Forum running slow
Replies: 18
Views: 10233

Re: Forum running slow

It's slow now, peak data rate according to my router's traffic statistics 60kByte/second, but takes a minute or so to open a page.
by Ektus
Wed Oct 03, 2018 6:19 pm
Forum: Applications
Topic: Application for test SM124 monitor
Replies: 4
Views: 1551

Re: Application for test SM124 monitor

Sorry, no, I don't think so. But Omikron.basic was delivered with a lot of Ataris on the language disc, it should be available everywhere a ST is.

Regards
Ektus.
by Ektus
Wed Oct 03, 2018 1:01 pm
Forum: Coding
Topic: Window refresh problems under Geneva/Neodesk
Replies: 64
Views: 5568

Re: Window refresh problems under Geneva/Neodesk

As for missing packages on a serial connection: Do you have HSMODEM installed to get a small buffer?

Search for archive HSMODA07, e.g. on https://sites.google.com/site/stessenti ... l-software

Regards
Ektus.
by Ektus
Wed Oct 03, 2018 6:02 am
Forum: Applications
Topic: Application for test SM124 monitor
Replies: 4
Views: 1551

Re: Application for test SM124 monitor

Check out http://www.stcarchiv.de/stc1990/SH/monitor-scharf-gemacht There's a small basic listing at the end that generates a test image. 1: ' OMICRON.BASIC-Programm zur 2: ' Testbilderzeugung für den 3: ' Abgleich des SM124 4 : 5: ' (c) MAXON Computer GmbH, 1990 6 : 7 : CLS 8: PRINT CHR$(27);"...

Go to advanced search