Search found 392 matches

by mpattonm
Tue Apr 30, 2019 7:00 pm
Forum: Hardware
Topic: Beginning of very long journey
Replies: 210
Views: 29378

Re: Beginning of very long journey

Well not much, but its still ongoing. I have discovered a bug in schematic I yet have to fix.
by mpattonm
Sun Apr 28, 2019 10:45 am
Forum: Hardware
Topic: Falcon DSP pinout
Replies: 19
Views: 934

Re: Falcon DSP pinout

Well they are all _physically_ connected on VCC or GND and the track width of each of their connection on Falcon PCB confirms they are indeed power pins, not just a (RX/TX) data lines tied say to ground. That would not make sence anyway.
by mpattonm
Sun Apr 28, 2019 7:38 am
Forum: Hardware
Topic: Falcon DSP pinout
Replies: 19
Views: 934

Re: Falcon DSP pinout

However, Falcon schematic says nothing much about the location of VCC and GND pins. So I kind of hope that TXD and RXD pins are still there undiscovered :) The extract I have sent you includes power pins mapping. If you just take a look at it and count all the pins, you will realize not a single pi...
by mpattonm
Sat Apr 27, 2019 6:46 pm
Forum: Hardware
Topic: Falcon DSP pinout
Replies: 19
Views: 934

Re: Falcon DSP pinout

There is no Motorola datasheet AFAIK. One of the options to cross-reference my attachement is Falcon schematic, for example.
by mpattonm
Sat Apr 27, 2019 5:42 pm
Forum: Hardware
Topic: Falcon DSP pinout
Replies: 19
Views: 934

Re: Falcon DSP pinout

Oh, right, sorry. Anyway, here is the complete pinout for SSP4240220FJ33-QFP80
by mpattonm
Sat Apr 27, 2019 5:29 pm
Forum: Hardware
Topic: Falcon DSP pinout
Replies: 19
Views: 934

Re: Falcon DSP pinout

Atari_Falcon030_Service_Guide.pdf
page 55
its missing power pins tho, so these have to be reverse engineered from Falcon PCB data. I may have a complete pinout, incl power, somewhere...
BTW those ~14 pins will be either NC, or power.
by mpattonm
Thu Mar 28, 2019 3:24 pm
Forum: Hardware
Topic: NetUSBee USB drivers download
Replies: 58
Views: 11480

Re: NetUSBee USB drivers download

Many thanks!
by mpattonm
Tue Mar 26, 2019 12:43 pm
Forum: CT60 / CT63 Area
Topic: Replacing CT60 boot logo with Didier's tools
Replies: 12
Views: 1613

Re: Replacing CT60 boot logo with Didier's tools

A simple end-user tool would be highly appreciated too.
by mpattonm
Tue Mar 26, 2019 6:39 am
Forum: CT60 / CT63 Area
Topic: New CT60 Boot ROM 1.05
Replies: 42
Views: 4507

Re: New CT60 Boot ROM 1.05

Oh, thats a feature I am waiting for :) Looking forward to it!
by mpattonm
Mon Mar 25, 2019 9:15 pm
Forum: CT60 / CT63 Area
Topic: New CT60 Boot ROM 1.05
Replies: 42
Views: 4507

Re: New CT60 Boot ROM 1.05

insane wrote:A small update: Boot 1.05 20190306 now shows [ ] Boot from CTPCI IDE Controller inside SETUP.

I noticed there is another update: 20190312, are there any significant fixes, changes?
by mpattonm
Mon Mar 18, 2019 7:07 am
Forum: CT60 / CT63 Area
Topic: Falcon Pal mobo and clock Patch owners
Replies: 14
Views: 854

Re: Falcon Pal mobo and clock Patch owners

Well the remote debugging of this kind is very difficult, but have you checked all the connectivity between Falcon motherboard and CT60? That is where I would start. Over the age, all the pinheaders become oxidated. Moreover, if they were mechanically stressed, solder joints develop hair cracks (col...
by mpattonm
Sat Mar 16, 2019 12:38 pm
Forum: Chat forum [ENG]
Topic: Oh please stop it. No seriously, you are beeing silly.
Replies: 0
Views: 539

Oh please stop it. No seriously, you are beeing silly.

I got bored today, so I dug a bit through the archive. Funny how time shad new light on these posts: Tue Apr 13, 2004 2:23 pm 120 LIVRES sterlling for the first falcon price ???? :evil: Too high you think? Wed Apr 27, 2005 12:35 pm There is also a Falcon 030 (seller is in Canada). http://cgi.ebay.ca...
by mpattonm
Fri Mar 15, 2019 8:41 pm
Forum: News & Announcements
Topic: MagiC/MagiCMacX source updated
Replies: 44
Views: 7278

Re: MagiC/MagiCMacX source updated

Apparently, there are no more commits since January, I sincerely hope you have not given up! Please keep on :)
by mpattonm
Fri Mar 15, 2019 8:19 pm
Forum: Hardware
Topic: NetUSBee USB drivers download
Replies: 58
Views: 11480

Re: NetUSBee USB drivers download

I have built my NetUSBee today and took a time to test it with drivers from this thread. I was stunned how solid USB flashdrive support is. Finally, I have a nice and convenient way to tranfer files between Ataris and a Win world. Thank you! The USB mouse support works equaly as well, as far as I ca...
by mpattonm
Fri Mar 01, 2019 10:09 am
Forum: CT60 / CT63 Area
Topic: CT60e is coming :)
Replies: 526
Views: 188328

Re: CT60e is coming :)

This is wher I get mine from:
https://www.ebay.co.uk/itm/1PC-For-Moto ... 3575053200
Its genuine rev. 6 as supposed to be, shipped fast and delivered in about 10 days. If it is used, as listed, then I have not found any marks of the use.
by mpattonm
Wed Feb 20, 2019 6:50 pm
Forum: Hardware
Topic: Falcon HDDriver problems
Replies: 3
Views: 877

Re: Falcon HDDriver problems

I would say post your issue here: https://www.hddriver.net/forum/
by mpattonm
Thu Feb 07, 2019 6:44 pm
Forum: CT60 / CT63 Area
Topic: ct60 with a pico psu - startup problematic
Replies: 31
Views: 3491

Re: ct60 with a pico psu - startup problematic

mikro wrote:Well, if you formulate a precise technical question / description, I can ask Rodolphe, he usually replies me quite quickly. ...

Will do, thanks!
by mpattonm
Thu Feb 07, 2019 6:38 pm
Forum: CT60 / CT63 Area
Topic: ct60 with a pico psu - startup problematic
Replies: 31
Views: 3491

Re: ct60 with a pico psu - startup problematic

Another one in the mix: PicoPSU120 from https://www.cartft.com Unlike previous PicoPSU90, this one is pretty good looking PSU, both in terms of build quality and on scope. Except for one parameter: 5V is delayed from 3.3V by some 4ms. And surprise, surprise - this one makes Falcon/CT60 start and wor...
by mpattonm
Wed Feb 06, 2019 11:10 pm
Forum: Professionals
Topic: Dead Falcon - no boot / coloured screen only
Replies: 38
Views: 3988

Re: Dead Falcon - no boot / coloured screen only

I second that, hot-air is the only sane option. Pre-heat the surrounding bottom area of the PCB (about 5x5cm, from bellow) to 230-250stC. Then pre-heat IC legs with a circular motion, top-down, same temperature. Quickly apply enough flux gel on all the legs and set the temperature to 380-400stC (yes...
by mpattonm
Tue Feb 05, 2019 10:46 pm
Forum: CT60 / CT63 Area
Topic: ct60 with a pico psu - startup problematic
Replies: 31
Views: 3491

Re: ct60 with a pico psu - startup problematic

ATX PSU specification says that Power Good signal has to switch from 0V to 5V not sooner as 100 ms after voltage is stable. To me this sounds as it is a good idea to connect the Power Good signal directly to the reset button or the reset signal. Does it make sense to try that? I wish it would be th...
by mpattonm
Mon Feb 04, 2019 10:12 pm
Forum: CT60 / CT63 Area
Topic: ct60 with a pico psu - startup problematic
Replies: 31
Views: 3491

Re: ct60 with a pico psu - startup problematic

Added third in the mix to my previous post here. As you can see Traco has both voltages at nominal levels virtually at the same time, the delta is around 0.1ms. Diametral ramps up 3.3V rail to nominal some 2ms before 5V rail does. ATX PSU has the time delta between the two about 3-4ms. Appearently i...
by mpattonm
Mon Feb 04, 2019 10:00 pm
Forum: Professionals
Topic: Dead Falcon - no boot / coloured screen only
Replies: 38
Views: 3988

Re: Dead Falcon - no boot / coloured screen only

as Greenious said it is probably Combo IC gone wrong. Did anyone mess waround the board with soldering iron on?
by mpattonm
Sun Feb 03, 2019 5:46 pm
Forum: CT60 / CT63 Area
Topic: ct60 with a pico psu - startup problematic
Replies: 31
Views: 3491

Re: ct60 with a pico psu - startup problematic

Yes, lower is 3.3V, upper is 5V. PWR_GOOD is not connected on/used by CT60 (shame, isnt it?). As for the C7 / reset line influence: I have already bigger capacity C7 soldered on, I guess its 22uF now. Thats why I can not repeat the tests with original (1uF ?) capacitor. Anyway, I do not see direct r...
by mpattonm
Sun Feb 03, 2019 11:45 am
Forum: CT60 / CT63 Area
Topic: FOUND
Replies: 1
Views: 2088

Re: Looking for CT60/63

Found btw :)

Go to advanced search